aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/pulseaudio.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-04-05 10:38:36 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-05 10:42:06 +0200
commitbbc4a8d238ee2f73ae3e16065fe4be4fd0e639aa (patch)
tree721c3df44023f3f7f12120da088a2db676655b84 /gnu/packages/pulseaudio.scm
parente382f1fb3c3848f13774b78b89eaab4e4eaa7a55 (diff)
downloadguix-bbc4a8d238ee2f73ae3e16065fe4be4fd0e639aa.tar
guix-bbc4a8d238ee2f73ae3e16065fe4be4fd0e639aa.tar.gz
gnu: libsndfile: Update to 1.2.0.
* gnu/packages/pulseaudio.scm (libsndfile): Update to 1.2.0. [origin]: Switch to git checkout. Drop snippet. [native-inputs]: Add packages needed for bootstrap phase.
Diffstat (limited to 'gnu/packages/pulseaudio.scm')
-rw-r--r--gnu/packages/pulseaudio.scm34
1 files changed, 12 insertions, 22 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index cadeccd660..ef4f8ba8cf 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -48,6 +48,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages audio)
+ #:use-module (gnu packages autogen)
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
#:use-module (gnu packages check)
@@ -76,38 +77,27 @@
(define-public libsndfile
(package
(name "libsndfile")
- (version "1.0.30")
+ (version "1.2.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/erikd/libsndfile"
- "/releases/download/v" version
- "/libsndfile-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libsndfile/libsndfile/")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "06k1wj3lwm7vf21s8yqy51k6nrkn9z610bj1gxb618ag5hq77wlx"))
- (modules '((ice-9 textual-ports) (guix build utils)))
+ "10lm5mn171ynykkvq5ad8m1zriv01w25s6hx0l3wphdd4p6f7c92"))
+ (modules '((guix build utils)))
(snippet
'(begin
- ;; Remove carriage returns (CRLF) to prevent bogus
- ;; errors from bash like "$'\r': command not found".
- (let ((data (call-with-input-file
- "tests/pedantic-header-test.sh.in"
- (lambda (port)
- (string-join
- (string-split (get-string-all port)
- #\return))))))
- (call-with-output-file "tests/pedantic-header-test.sh.in"
- (lambda (port) (format port data))))
-
- ;; While at it, fix hard coded executable name.
+ ;; Fix hard coded executable name.
(substitute* "tests/test_wrapper.sh.in"
- (("^/usr/bin/env") "env"))
- #t))))
+ (("^/usr/bin/env") "env"))))))
(build-system gnu-build-system)
(propagated-inputs
(list flac libogg libvorbis opus))
(native-inputs
- (list pkg-config python))
+ (list autoconf autogen automake libtool pkg-config python))
(home-page "http://www.mega-nerd.com/libsndfile/")
(synopsis "Reading and writing files containing sampled sound")
(description