aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-11-11 16:45:46 +0800
committerMathieu Othacehe <othacehe@gnu.org>2023-11-25 14:47:51 +0100
commita077907226d2f0d1345a661f7b285336ee858c10 (patch)
treeeda19d5565af5c3983571ae340e3870766520d2a /gnu/packages/protobuf.scm
parent7ae33c70f0183dab49a8b03e95505c08974c38a8 (diff)
downloadguix-a077907226d2f0d1345a661f7b285336ee858c10.tar
guix-a077907226d2f0d1345a661f7b285336ee858c10.tar.gz
gnu: protobuf: Fix cross-compilation.
* gnu/packages/protobuf.scm (protobuf): Fix cross-compilation. [native-inputs]: When cross-compiling, add this-package. [inputs]: Add googletest. Change-Id: Id7d3a8be9d4211249c0adc3a99a7a07206f9c495 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 8cd805799e..c157eabce0 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -156,8 +157,11 @@ data in motion, or as a file format for data at rest.")
(install-file file slib)
(delete-file file))
(find-files lib "\\.a$"))))))))
- (native-inputs (list googletest))
- (inputs (list zlib))
+ (native-inputs (append (if (%current-target-system)
+ (list this-package)
+ '())
+ (list googletest)))
+ (inputs (list zlib googletest))
(home-page "https://github.com/protocolbuffers/protobuf")
(synopsis "Data encoding for remote procedure calls (RPCs)")
(description