aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 11:06:22 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 11:18:13 -0400
commit07fdfb9e1eb966a83ed99559416be7c72a64a4a2 (patch)
treef95398322a34c08728109ceba9e99517eada4b92 /gnu/packages/protobuf.scm
parent094505d56cf1b61962671fff9e14ef2c21076242 (diff)
downloadguix-07fdfb9e1eb966a83ed99559416be7c72a64a4a2.tar
guix-07fdfb9e1eb966a83ed99559416be7c72a64a4a2.tar.gz
gnu: protobuf-2: Fix build.
Partially fixes <https://issues.guix.gnu.org/51093>. * gnu/packages/protobuf.scm (protobuf-2) [phases]{disable-broken-tests}: Delete phase.
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index f66e3469b8..daf7b933ad 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017, 2018, 2019, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
@@ -180,7 +180,11 @@ internal RPC protocols and file formats.")
version ".tar.bz2"))
(sha256
(base32
- "040rcs9fpv4bslhiy43v7dcrzakz4vwwpyqg4jp8bn24sl95ci7f"))))))
+ "040rcs9fpv4bslhiy43v7dcrzakz4vwwpyqg4jp8bn24sl95ci7f"))))
+ (arguments (substitute-keyword-arguments (package-arguments protobuf)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (delete 'disable-broken-tests)))))))
(define-public protobuf-c
(package