aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/potassco.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-16 19:27:33 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-23 09:29:05 +0100
commit5023424f16029ed8e24dc2b2ba8eba5812ece26b (patch)
treed5db297c8c92c3ba5570e113711de5fb37aace39 /gnu/packages/potassco.scm
parent540f248c51a1950dc4b0b8430edf05ac7b6f4394 (diff)
downloadguix-5023424f16029ed8e24dc2b2ba8eba5812ece26b.tar
guix-5023424f16029ed8e24dc2b2ba8eba5812ece26b.tar.gz
gnu: Add clingo-dl.
* gnu/packages/potassco.scm (clingo-dl): New variable. Change-Id: Ib6ff517435a614c3625d042453db05fe518241cd
Diffstat (limited to 'gnu/packages/potassco.scm')
-rw-r--r--gnu/packages/potassco.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index e6d7caa1ef..887c220ccf 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -221,6 +221,28 @@ satisfiability checking (SAT).")
(description "Clingo computes answer sets for a given logic program.")
(license license:expat)))
+(define-public clingo-dl
+ (package
+ (name "clingo-dl")
+ (version "1.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/potassco/clingo-dl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dncwj63vdm6958vb7355d5j9mdr7hm037j4z82yz6l77jg3sipw"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f ; no tests
+ #:configure-flags #~`("-DPYCLINGODL_ENABLE=off")))
+ (inputs (list clingo))
+ (home-page "https://github.com/potassco/clingo-dl")
+ (synopsis "Solver for answer set programs modulo difference constraints")
+ (description "Clingo-DL is an extension to Clingo that models constraints
+over difference logic.")
+ (license license:expat)))
+
(define-public emacs-pasp-mode
(let ((commit "59385eb0e8ebcfc8c11dd811fb145d4b0fa3cc92")
(revision "1"))