aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/polkit.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <me@jeandudey.tech>2022-06-27 12:18:05 +0200
committerMarius Bakke <marius@gnu.org>2022-07-20 15:02:13 +0200
commit7767d30f55a0fa280d716630d5db3771c122e621 (patch)
treed7186efcefd0049325e8bb93be8222da89555565 /gnu/packages/polkit.scm
parent8d241c685a35227cd6b733dc16a5ca9a60480722 (diff)
downloadguix-7767d30f55a0fa280d716630d5db3771c122e621.tar
guix-7767d30f55a0fa280d716630d5db3771c122e621.tar.gz
gnu: polkit-mozjs: Fix native-inputs on stage.
* gnu/packages/polkit.scm (polkit-duktape)[arguments]: Change the use of `inputs' to `(or native-inputs inputs)' when searching for `docbook-xsl' path. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/polkit.scm')
-rw-r--r--gnu/packages/polkit.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index a75608cd43..9a3703b196 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -119,10 +120,11 @@
(("@INTROSPECTION_TYPELIBDIR@")
(string-append out "/lib/girepository-1.0/"))))))
(add-after 'unpack 'fix-manpage-generation
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xsldoc (string-append (assoc-ref inputs "docbook-xsl")
- "/xml/xsl/docbook-xsl-"
- ,(package-version docbook-xsl))))
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (let ((xsldoc (string-append
+ (assoc-ref (or native-inputs inputs) "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl))))
(substitute* '("docs/man/Makefile.am" "docs/man/Makefile.in")
(("http://docbook.sourceforge.net/release/xsl/current")
xsldoc)))))