aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/plotutils.scm
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2023-03-13 22:53:03 +0900
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-02 22:28:53 +0200
commitbaaea549043df87a364af100c1e8847519d3ccdc (patch)
tree359dbfe0371260a116795ea4d90d2a8ce8c75f48 /gnu/packages/plotutils.scm
parentb2d70729bb7c535e2e79df19b71a72a180386456 (diff)
downloadguix-baaea549043df87a364af100c1e8847519d3ccdc.tar
guix-baaea549043df87a364af100c1e8847519d3ccdc.tar.gz
gnu: Add youplot.
* gnu/packages/plotutils.scm (youplot): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/plotutils.scm')
-rw-r--r--gnu/packages/plotutils.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 34f507e825..fdda6d4871 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -456,3 +456,29 @@ characters. Supported charts are: barplot, boxplot, densityplot,
histogram, lineplot, and scatterplot.")
(home-page "https://github.com/red-data-tools/unicode_plot.rb")
(license license:expat)))
+
+(define-public youplot
+ (package
+ (name "youplot")
+ (version "0.4.5")
+ ;; Source at RubyGems.org doesn't have tests.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/red-data-tools/YouPlot")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1y54apw7hx9mhjnf277w9wayvq954mdnip4dpajhc0qjg2464c2b"))))
+ (build-system ruby-build-system)
+ (native-inputs (list ruby-rake ruby-simplecov ruby-test-unit))
+ (propagated-inputs (list ruby-unicode-plot))
+ (synopsis "Command line tool that draw plots on the terminal")
+ (description
+ "YouPlot is a command line tool that draws plots on the terminal,
+powered by UnicodePlot gem. It provides commands @command{youplot}
+and @command{uplot} (shorthand) are provided, and supports chart types
+of barplot, histogram, lineplot, scatter, density, boxplot, and count.")
+ (home-page "https://github.com/red-data-tools/YouPlot")
+ (license license:expat)))