aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/pkg-config.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-12 12:51:15 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:59 -0400
commiteda94d13d4b1845c398ceee34c6bff7364bceaa6 (patch)
tree609c0cf83010e60ef50386b7fc00eb93a386d13c /gnu/packages/pkg-config.scm
parent028b60a985abe4870156735e1efcd9d85f886132 (diff)
downloadguix-eda94d13d4b1845c398ceee34c6bff7364bceaa6.tar
guix-eda94d13d4b1845c398ceee34c6bff7364bceaa6.tar.gz
gnu: Add pkgconf.
* gnu/packages/pkg-config.scm (pkgconf): New variable.
Diffstat (limited to 'gnu/packages/pkg-config.scm')
-rw-r--r--gnu/packages/pkg-config.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/pkg-config.scm b/gnu/packages/pkg-config.scm
index 770426d779..6263e90f1f 100644
--- a/gnu/packages/pkg-config.scm
+++ b/gnu/packages/pkg-config.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2012, 2013, 2014, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -167,3 +168,26 @@ exec ~a \"$@\""
(inherit original)
(variable "PKG_CONFIG_PATH_FOR_BUILD")))
(package-native-search-paths %pkg-config)))))
+
+(define-public pkgconf
+ (package
+ (name "pkgconf")
+ (version "1.9.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://distfiles.dereferenced.org/"
+ name "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "17b9cl2s99pzgblaj0yg49k3m0by5x78vwg4879vckymhys5bcsz"))))
+ (build-system gnu-build-system)
+ (arguments (list #:tests? #f)) ;TODO: package kyua
+ (home-page "http://pkgconf.org/")
+ (synopsis "Package compiler and linker metadata toolkit")
+ (description "@command{pkgconf} is a program which helps to configure
+compiler and linker flags for development libraries. It is similar to
+pkg-config from freedesktop.org. @code{libpkgconf} is a library which
+provides access to most of pkgconf's functionality, to allow other tooling
+such as compilers and IDEs to discover and use libraries configured by
+pkgconf.")
+ (license isc)))