aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl6.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-29 05:17:52 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-03-04 10:41:57 +0200
commit8dca56b4a1776e70e9880039528cdadee56d8526 (patch)
tree0257637a5def04ad1aacc5aefb86de65c0f79dc4 /gnu/packages/perl6.scm
parent6a80ac450c835c146a2b5102d36e9af17a1d1d2d (diff)
downloadguix-8dca56b4a1776e70e9880039528cdadee56d8526.tar
guix-8dca56b4a1776e70e9880039528cdadee56d8526.tar.gz
gnu: perl6-tap-harness: Update to 0.3.5.
* gnu/packages/perl6.scm (perl6-tap-harness): Update to 0.3.5. [source]: Update URL. Reindent. [arguments]: Replace obsolete prove6 script with manual Raku invocation in 'check' phase. [home-page]: Update. [synopsis]: Replace mention of Perl with Raku. * gnu/packages/rakudo-build-system.scm (check): Replace obsolete prove6 script with manual Raku invocation. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/perl6.scm')
-rw-r--r--gnu/packages/perl6.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 3dfdeec4f1..d61868f8b2 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -680,17 +680,16 @@ with optional labels, or xy plots).")
(define-public perl6-tap-harness
(package
(name "perl6-tap-harness")
- (version "0.0.7")
+ (version "0.3.5")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/perl6/tap-harness6")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1lig8i0my3fgqvlay9532xslbf3iis2d7wz89gniwvwqffi2kh6r"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Raku/tap-harness6")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "162crdy8g6xhnry26pjma2panm0c79n26igmljg79al4bqj9lyc9"))))
(build-system rakudo-build-system)
(arguments
'(#:with-zef? #f
@@ -699,9 +698,9 @@ with optional labels, or xy plots).")
(modify-phases %standard-phases
(replace 'check
(lambda _
- (invoke "perl6" "-Ilib" "bin/prove6" "-l" "t"))))))
- (home-page "https://github.com/perl6/tap-harness6/")
- (synopsis "TAP harness for perl6")
+ (apply invoke "raku" "-MTAP" "-Ilib" (find-files "t" "\\.t$")))))))
+ (home-page "https://github.com/Raku/tap-harness6")
+ (synopsis "TAP harness for Raku")
(description "This module provides the @command{prove6} command which runs a
TAP based test suite and prints a report. The @command{prove6} command is a
minimal wrapper around an instance of this module.")