aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl6.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-29 05:18:18 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-03-04 10:41:57 +0200
commit189333f9c04f64d000c2a08478875806f9e691eb (patch)
tree5e086d78f569fb8a33212e4f153bf0bdb258b7a8 /gnu/packages/perl6.scm
parent3471ab0a13de1bcec1afb6621062f4b19ffad71f (diff)
downloadguix-189333f9c04f64d000c2a08478875806f9e691eb.tar
guix-189333f9c04f64d000c2a08478875806f9e691eb.tar.gz
gnu: perl6-grammar-profiler-simple: Perl -> Raku.
* gnu/packages/perl6.scm (perl6-grammar-profiler-simple)[source]: Reindent. [synopsis, description]: Replace mentions of Perl with Raku. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/perl6.scm')
-rw-r--r--gnu/packages/perl6.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index cfc6d2d504..d25afa5528 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -333,27 +333,26 @@ prompt.")
(license license:artistic2.0))))
(define-public perl6-grammar-profiler-simple
- ;; Last commit was June 2017
+ ;; Last commit was June 2017.
(let ((commit "c0aca5fab323b2974821dabd6b89330c609e0b7d")
(revision "1"))
(package
(name "perl6-grammar-profiler-simple")
(version (git-version "0.02" revision commit))
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/perlpilot/Grammar-Profiler-Simple")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1qcsa4lmcilp3vp0jng0hrgzyzxin9ayg2wjvkcd0k6h7djx9dff"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/perlpilot/Grammar-Profiler-Simple")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qcsa4lmcilp3vp0jng0hrgzyzxin9ayg2wjvkcd0k6h7djx9dff"))))
(build-system rakudo-build-system)
(arguments '(#:with-zef? #f))
(home-page "https://github.com/perlpilot/Grammar-Profiler-Simple")
- (synopsis "Simple rule profiling for Perl 6 grammars")
- (description "This module provides a simple profiler for Perl 6 grammars.
+ (synopsis "Simple rule profiling for Raku grammars")
+ (description "This module provides a simple profiler for Raku grammars.
To enable profiling simply add use @code{Grammar::Profiler::Simple;} to your
code. Any grammar in the lexical scope of the use statement will automatically
have profiling information collected when the grammar is used.")