aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2022-10-17 22:38:13 -0300
committerChristopher Baines <mail@cbaines.net>2022-10-18 10:58:48 +0100
commitb91a5667c61bd9c55e70dd86418ccf0a5040736a (patch)
tree42d16be22f2642e65aff77dca730d0c2c83b594b /gnu/packages/perl.scm
parent885944bc1075318eb86185de5782212dbbe36baf (diff)
downloadguix-b91a5667c61bd9c55e70dd86418ccf0a5040736a.tar
guix-b91a5667c61bd9c55e70dd86418ccf0a5040736a.tar.gz
gnu: Add perl-readonly-xs.
* gnu/packages/perl.scm (perl-readonly-xs): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index c98d3429ed..15138d453f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8854,6 +8854,38 @@ can also be useful as a development and debugging tool for catching updates to
variables that should not be changed.")
(license (package-license perl))))
+(define-public perl-readonly-xs
+ (package
+ (name "perl-readonly-xs")
+ (version "1.05")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RO/ROODE/Readonly-XS-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "03gz7yp194fwah2bc36ww04hgw1qx8p6y68vvnywircrablc9rca"))))
+ (build-system perl-build-system)
+ (propagated-inputs (list perl-readonly))
+ (home-page "https://metacpan.org/release/Readonly-XS")
+ (synopsis "Companion module for @code{Readonly.pm}, to speed up read-only
+scalar variables")
+ (description
+ "The @code{Readonly} module is an effective way to create non-modifiable
+variables. However, it's relatively slow.
+
+The reason it's slow is that is implements the read-only-ness of variables via
+tied objects. This mechanism is inherently slow. Perl simply has to do a lot
+of work under the hood to make tied variables work.
+
+This module corrects the speed problem, at least with respect to scalar
+variables. When @code{Readonly::XS} is installed, @code{Readonly} uses it to
+access the internals of scalar variables. Instead of creating a scalar variable
+object and tying it, @code{Readonly} simply flips the @code{SvREADONLY} bit in
+the scalar's @code{FLAGS} structure.")
+ (license license:perl-license)))
+
(define-public perl-ref-util-xs
(package
(name "perl-ref-util-xs")