aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-09-02 19:59:04 +0100
committerChristopher Baines <mail@cbaines.net>2022-09-10 10:45:27 +0100
commitad1d3f98b1d6f498d7f3e13d810f417ef3e7df5d (patch)
tree9af5deea8301f80d15347d6f98ea43a269f18db6 /gnu/packages/perl.scm
parent4f134f26fd9e4feb799b21157424af216be3d267 (diff)
downloadguix-ad1d3f98b1d6f498d7f3e13d810f417ef3e7df5d.tar
guix-ad1d3f98b1d6f498d7f3e13d810f417ef3e7df5d.tar.gz
gnu: Add comments to the bottom of a few package modules.
This will hopefully discourage patches which add new packages to the bottom of files, as this increases the likelihood of conflicts when applying patches. If there are more specific ways that packages should be arranged in specific modules, this message can be updated accordingly. * gnu/packages/bioconductor.scm: Add comment discouraging adding packages to the bottom of the file. * gnu/packages/bioinformatics.scm: ditto. * gnu/packages/cran.scm: ditto. * gnu/packages/crates-io.scm: ditto. * gnu/packages/emacs-xyz.scm: ditto. * gnu/packages/golang.scm: ditto. * gnu/packages/guile-xyz.scm: ditto. * gnu/packages/haskell-xyz.scm: ditto. * gnu/packages/java.scm: ditto. * gnu/packages/julia-xyz.scm: ditto. * gnu/packages/lisp-xyz.scm: ditto. * gnu/packages/ocaml.scm: ditto. * gnu/packages/perl.scm: ditto. * gnu/packages/python-science.scm: ditto. * gnu/packages/python-xyz.scm: ditto. * gnu/packages/ruby.scm: ditto. * gnu/packages/tex.scm: ditto.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 42c7d18c9d..64868607dc 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11901,3 +11901,9 @@ It also allows manipulating ancillary data or so-called control
information (cmsghdr). This ancillary data may be used for file descriptor
passing, IPv6 operations, and a host of implemenation-specific extensions.")
(license license:perl-license)))
+
+;;;
+;;; Avoid adding new packages to the end of this file. To reduce the chances
+;;; of a merge conflict, place them above by existing packages with similar
+;;; functionality or similar names.
+;;;