aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2022-12-31 23:04:56 +0900
committerJulien Lepiller <julien@lepiller.eu>2023-01-03 20:51:22 +0100
commit62ee1c4b47c6e1e62314223d62a5d54162a23fa8 (patch)
tree26e2233cf339b7d818ac98c42b23bbdcc93ad07d /gnu/packages/perl.scm
parentaf74211d987d2b8510e2f4937e65f6480754886f (diff)
downloadguix-62ee1c4b47c6e1e62314223d62a5d54162a23fa8.tar
guix-62ee1c4b47c6e1e62314223d62a5d54162a23fa8.tar.gz
gnu: Add perl-text-charwidth.
* gnu/packages/perl.scm (perl-text-charwidth): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f80d84eaa5..7f85c2a66a 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
+;;; Copyright © 2022 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10471,6 +10472,27 @@ used to justify strings to various alignment styles.")
text sequences from strings.")
(license (package-license perl))))
+(define-public perl-text-charwidth
+ (package
+ (name "perl-text-charwidth")
+ (version "0.04")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/K/KU/KUBOTA/Text-CharWidth-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1y040wiqx78pnr0wxbjhpzjxm2a9qiqq479gzn4qwcyrzpsdbpmb"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/dist/Text-CharWidth")
+ (synopsis "Get number of occupied columns of a string on terminal")
+ (description
+ "With this module, you can calculate terminal character
+widths that vary by locale. This module supplies features similar to
+wcwidth(3) and wcswidth(3) in C language.")
+ (license (package-license perl))))
+
(define-public perl-text-csv
(package
(name "perl-text-csv")