aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2022-10-17 22:38:11 -0300
committerChristopher Baines <mail@cbaines.net>2022-10-18 10:58:47 +0100
commit5f30ce031493d9ae9d4488ffc7e64c004cb8be6b (patch)
tree7f48b1f62f485a605e6e60562eefe86812f9ae7f /gnu/packages/perl.scm
parent5595aa9a75f05440ae3c77b9bae282f89b7c47b8 (diff)
downloadguix-5f30ce031493d9ae9d4488ffc7e64c004cb8be6b.tar
guix-5f30ce031493d9ae9d4488ffc7e64c004cb8be6b.tar.gz
gnu: Add perl-config-tiny.
* gnu/packages/perl.scm (perl-config-tiny): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index e111fcd943..4624b5ab6d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2076,6 +2076,33 @@ of the style used by the Git version control system.")
and writing of @code{.ini}-style configuration files.")
(license (package-license perl))))
+(define-public perl-config-tiny
+ (package
+ (name "perl-config-tiny")
+ (version "2.28")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RS/RSAVAGE/Config-Tiny-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "000mw17nb7aj341s0afqimxd53w5y0c4yk61pihqzm191lx89pqj"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-test-pod))
+ (home-page "https://metacpan.org/release/Config-Tiny")
+ (synopsis "Read/Write .ini style files with as little code as possible")
+ (description
+ "@code{Config::Tiny} is a Perl class to read and write .ini
+style configuration files with as little code as possible, reducing load time
+and memory overhead.
+
+This module is primarily for reading human written files, and anything we write
+shouldn't need to have documentation/comments. If you need something with more
+power move up to @code{Config::Simple}, @code{Config::General} or one of the
+many other @code{Config::*} modules.")
+ (license license:perl-license)))
+
(define-public perl-const-fast
(package
(name "perl-const-fast")