aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorRikard Nordgren <hrn@posteo.net>2023-06-05 18:44:21 +0000
committer宋文武 <iyzsong@member.fsf.org>2023-07-22 11:29:31 +0800
commitfb52f687f79fb74f724abd1835e18bad6a2901e6 (patch)
tree5bdfeb162fa698d1f1a3c97a47466c5429632a1e /gnu/packages/perl-check.scm
parent7a6294ba0580efe9f19a1771c267a2bd511d1039 (diff)
downloadguix-fb52f687f79fb74f724abd1835e18bad6a2901e6.tar
guix-fb52f687f79fb74f724abd1835e18bad6a2901e6.tar.gz
gnu: Add perl-test-inter.
* gnu/packages/perl-check.scm (perl-test-inter): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 7bf58832bc..5ef56227ce 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -39,6 +39,7 @@
#:use-module (gnu packages web)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system perl)
#:use-module (gnu packages perl))
@@ -715,6 +716,29 @@ contents of a file is equal to a particular string.")
automatically aggregated and output to STDOUT.")
(license perl-license)))
+(define-public perl-test-inter
+ (package
+ (name "perl-test-inter")
+ (version "1.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SBECK-github/Test-Inter")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ii3avmd31j3kxg456jqvlj5w0hpywpj51mqm4ccnjm820yv8irb"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/pod/Test::Inter")
+ (synopsis "Framework for more readable interactive test scripts")
+ (description
+ "@code{Test::Inter} is another framework for writing test scripts, which
+offer the ability to access specific tests in a reasonably interactive
+fashion, primarily for debugging purposes. Much of the syntax is loosely
+inspired by @code{Test::More}.")
+ (license perl-license)))
+
(define-public perl-test-leaktrace
(package
(name "perl-test-leaktrace")