aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-08-01 13:56:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-02 09:20:40 +0300
commit635e20aae904263418fb2939de355ba1ca111672 (patch)
tree3d6efaeb0f7055416304863c7174de00c8b03151 /gnu/packages/pcre.scm
parentb89be0f5d2f831c36e217c67461a2b2cf277529f (diff)
downloadguix-635e20aae904263418fb2939de355ba1ca111672.tar
guix-635e20aae904263418fb2939de355ba1ca111672.tar.gz
gnu: pcre2: Enable JIT support of powerpc-linux.
* gnu/packages/pcre.scm (pcre2)[arguments]: When building for powerpc-linux use the compile flag to enable jit support.
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index bc1e7a73e0..ee48ad0e2b 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -111,9 +111,8 @@ POSIX regular expression API.")
"--enable-pcre2test-libreadline"
"--enable-pcre2-16"
"--enable-pcre2-32"
- ;; pcre2_jit_test fails on powerpc32.
;; riscv64-linux is an unsupported architecture.
- #$@(if (or (target-ppc32?) (target-riscv64?))
+ #$@(if (target-riscv64?)
#~()
#~("--enable-jit"))
"--disable-static")