aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-10 22:09:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-10 22:09:49 +0100
commitfc891f004aff40e34c23fc101aeea5d05e7555ae (patch)
treee5d6b12a0b2e998ad78e81ec2ed90366113e5d88 /gnu/packages/patches
parenta252ab6f889fc8530e081da5361774179de4b146 (diff)
downloadguix-fc891f004aff40e34c23fc101aeea5d05e7555ae.tar
guix-fc891f004aff40e34c23fc101aeea5d05e7555ae.tar.gz
gnu: openjdk10: Fix time bomb in ‘GenerateCurrencyData.java’.
Fixes <https://issues.guix.gnu.org/68333>, as well. This is a companion to commit 5c0f77f4241c9beac0c82deae946bfdc70b49ff0. * gnu/packages/java.scm (openjdk10)[source]: Add patch. * gnu/packages/patches/openjdk-currency-time-bomb2.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Change-Id: I42fc14d305883f672cd6764a0ee6462852e41a5b
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/openjdk-currency-time-bomb2.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/openjdk-currency-time-bomb2.patch b/gnu/packages/patches/openjdk-currency-time-bomb2.patch
new file mode 100644
index 0000000000..d2ea04d63b
--- /dev/null
+++ b/gnu/packages/patches/openjdk-currency-time-bomb2.patch
@@ -0,0 +1,13 @@
+Fix a time bomb present in the OpenJDK tools.
+
+--- a/make/jdk/src/classes/build/tools/generatecurrencydata/GenerateCurrencyData.java
++++ b/make/jdk/src/classes/build/tools/generatecurrencydata/GenerateCurrencyData.java
+@@ -285,7 +285,7 @@ public class GenerateCurrencyData {
+ String timeString = currencyInfo.substring(4, length - 4);
+ long time = format.parse(timeString).getTime();
+ if (Math.abs(time - System.currentTimeMillis()) > ((long) 10) * 365 * 24 * 60 * 60 * 1000) {
+- throw new RuntimeException("time is more than 10 years from present: " + time);
++ System.err.println("note: time is more than 10 years from \"present\": " + time);
+ }
+ specialCaseCutOverTimes[specialCaseCount] = time;
+ specialCaseOldCurrencies[specialCaseCount] = oldCurrency;