aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-17 21:08:35 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:48 +0200
commitf645cf65c1fa64727aade341849d38776d46d518 (patch)
tree3b94802c6c568aa31124079e4bb66f4967a3747d /gnu/packages/patches
parent2b93fed8fa9881bd7924f80bf1f0f735d7787fb7 (diff)
downloadguix-f645cf65c1fa64727aade341849d38776d46d518.tar
guix-f645cf65c1fa64727aade341849d38776d46d518.tar.gz
gnu: file: Fix building on 32-bit systems.
* gnu/packages/file.scm (file)[source]: Add patch. * gnu/packages/patches/file-32bit-time.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I9511769647147eb79db2babaaa606816d77fadad
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/file-32bit-time.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/patches/file-32bit-time.patch b/gnu/packages/patches/file-32bit-time.patch
new file mode 100644
index 0000000000..671bcfdf66
--- /dev/null
+++ b/gnu/packages/patches/file-32bit-time.patch
@@ -0,0 +1,40 @@
+Upstream uses CVS, this is taken from the Github mirror
+https://github.com/file/file/commit/218fdf813fd5ccecbb8887a1b62509cd1c6dd3a1.patch
+https://sources.debian.org/src/file/1%3A5.45-2/debian/patches/1690555105.FILE5_45-1-g218fdf81.deal-with-32-bit-time-t.patch/
+
+From 218fdf813fd5ccecbb8887a1b62509cd1c6dd3a1 Mon Sep 17 00:00:00 2001
+From: Christos Zoulas <christos@zoulas.com>
+Date: Fri, 28 Jul 2023 14:38:25 +0000
+Subject: [PATCH] deal with 32 bit time_t
+
+---
+ src/file.h | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/src/file.h b/src/file.h
+index 2e0494d2f..78f574ea1 100644
+--- a/src/file.h
++++ b/src/file.h
+@@ -27,7 +27,7 @@
+ */
+ /*
+ * file.h - definitions for file(1) program
+- * @(#)$File: file.h,v 1.247 2023/07/27 19:40:22 christos Exp $
++ * @(#)$File: file.h,v 1.248 2023/07/28 14:38:25 christos Exp $
+ */
+
+ #ifndef __file_h__
+@@ -159,9 +159,11 @@
+ /*
+ * Dec 31, 23:59:59 9999
+ * we need to make sure that we don't exceed 9999 because some libc
+- * implementations like muslc crash otherwise
++ * implementations like muslc crash otherwise. If you are unlucky
++ * to be running on a system with a 32 bit time_t, then it is even less.
+ */
+-#define MAX_CTIME CAST(time_t, 0x3afff487cfULL)
++#define MAX_CTIME \
++ CAST(time_t, sizeof(time_t) > 4 ? 0x3afff487cfULL : 0x7fffffffULL)
+
+ #define FILE_BADSIZE CAST(size_t, ~0ul)
+ #define MAXDESC 64 /* max len of text description/MIME type */