aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-06-03 08:18:54 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-06-03 08:32:26 +0200
commit742d5c3d68c8b83ef594a5aeb870e27255c3726a (patch)
treee01c6676c54f41095362202d8aa9a838790a4844 /gnu/packages/patches
parent52b4ce275fda390172fcce9797300ba0d5a89d59 (diff)
parentc11b92a8aae6fe7fad0da8257ec28f5009c37b35 (diff)
downloadguix-742d5c3d68c8b83ef594a5aeb870e27255c3726a.tar
guix-742d5c3d68c8b83ef594a5aeb870e27255c3726a.tar.gz
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/c++-gsl-find-system-gtest.patch96
-rw-r--r--gnu/packages/patches/c++-gsl-move-array-bounds-tests.patch126
-rw-r--r--gnu/packages/patches/libtommath-integer-overflow.patch140
-rw-r--r--gnu/packages/patches/python-docrepr-fix-tests.patch16
-rw-r--r--gnu/packages/patches/python-ipython-documentation-chars.patch18
-rw-r--r--gnu/packages/patches/python-ipython-documentation-repro.patch25
-rw-r--r--gnu/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch28
-rw-r--r--gnu/packages/patches/webrtc-for-telegram-desktop-fix-gcc12-cstdint.patch21
8 files changed, 170 insertions, 300 deletions
diff --git a/gnu/packages/patches/c++-gsl-find-system-gtest.patch b/gnu/packages/patches/c++-gsl-find-system-gtest.patch
deleted file mode 100644
index 2def650292..0000000000
--- a/gnu/packages/patches/c++-gsl-find-system-gtest.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-From f5cf01083baf7e8dc8318db3648bc6098dc32d67 Mon Sep 17 00:00:00 2001
-From: Nicholas Guriev <guriev-ns@ya.ru>
-Date: Sat, 18 Apr 2020 13:30:17 +0300
-Subject: [PATCH] Search for GoogleTest via pkg-config first
-
----
- tests/CMakeLists.txt | 55 ++++++++++++++++++++++++--------------------
- 1 file changed, 30 insertions(+), 25 deletions(-)
-
-diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
-index 02193197..53d475c2 100644
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -1,36 +1,41 @@
- cmake_minimum_required(VERSION 3.0.2)
-
- project(GSLTests CXX)
-+include(FindPkgConfig)
-
- # will make visual studio generated project group files
- set_property(GLOBAL PROPERTY USE_FOLDERS ON)
-
--configure_file(CMakeLists.txt.in googletest-download/CMakeLists.txt)
--execute_process(
-- COMMAND ${CMAKE_COMMAND} -G "${CMAKE_GENERATOR}" .
-- RESULT_VARIABLE result
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/googletest-download
--)
--if(result)
-- message(FATAL_ERROR "CMake step for googletest failed: ${result}")
--endif()
-+pkg_search_module(GTestMain gtest_main)
-+if (NOT GTestMain_FOUND)
-+ configure_file(CMakeLists.txt.in googletest-download/CMakeLists.txt)
-+ execute_process(
-+ COMMAND ${CMAKE_COMMAND} -G "${CMAKE_GENERATOR}" .
-+ RESULT_VARIABLE result
-+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/googletest-download
-+ )
-+ if(result)
-+ message(FATAL_ERROR "CMake step for googletest failed: ${result}")
-+ endif()
-
--execute_process(
-- COMMAND ${CMAKE_COMMAND} --build .
-- RESULT_VARIABLE result
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/googletest-download
--)
--if(result)
-- message(FATAL_ERROR "CMake step for googletest failed: ${result}")
--endif()
-+ execute_process(
-+ COMMAND ${CMAKE_COMMAND} --build .
-+ RESULT_VARIABLE result
-+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/googletest-download
-+ )
-+ if(result)
-+ message(FATAL_ERROR "CMake step for googletest failed: ${result}")
-+ endif()
-
--set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
-+ set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
-+ set(GTestMain_LIBRARIES gtest_main)
-
--add_subdirectory(
-- ${CMAKE_CURRENT_BINARY_DIR}/googletest-src
-- ${CMAKE_CURRENT_BINARY_DIR}/googletest-build
-- EXCLUDE_FROM_ALL
--)
-+ add_subdirectory(
-+ ${CMAKE_CURRENT_BINARY_DIR}/googletest-src
-+ ${CMAKE_CURRENT_BINARY_DIR}/googletest-build
-+ EXCLUDE_FROM_ALL
-+ )
-+endif()
-
- if (MSVC AND (GSL_CXX_STANDARD EQUAL 17))
- set(GSL_CPLUSPLUS_OPT -Zc:__cplusplus -permissive-)
-@@ -149,7 +154,7 @@ function(add_gsl_test name)
- target_link_libraries(${name}
- GSL
- gsl_tests_config
-- gtest_main
-+ ${GTestMain_LIBRARIES}
- )
- add_test(
- ${name}
-@@ -254,7 +259,7 @@ function(add_gsl_test_noexcept name)
- target_link_libraries(${name}
- GSL
- gsl_tests_config_noexcept
-- gtest_main
-+ ${GTestMain_LIBRARIES}
- )
- add_test(
- ${name}
diff --git a/gnu/packages/patches/c++-gsl-move-array-bounds-tests.patch b/gnu/packages/patches/c++-gsl-move-array-bounds-tests.patch
deleted file mode 100644
index 0629212688..0000000000
--- a/gnu/packages/patches/c++-gsl-move-array-bounds-tests.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-Description: Move tests that trigger -Warray-bounds to separate compilation unit
- GCC 10 is now smart enough to detect violation of array boundaries that tests
- are actually tested. Along with -Werror this led to tests failure, so I move
- such tests to another compilation unit to have the warning deactivated for
- only these tests.
-Bug-Debian: https://bugs.debian.org/966895
-Author: Nicholas Guriev <guriev-ns@ya.ru>
-Last-Modified: Wed, 19 Aug 2020 08:55:52 +0300
-
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -179,6 +179,7 @@ add_gsl_test(owner_tests)
- add_gsl_test(byte_tests)
- add_gsl_test(algorithm_tests)
- add_gsl_test(strict_notnull_tests)
-+add_gsl_test(array_bounds)
-
-
- # No exception tests
---- /dev/null
-+++ b/tests/array_bounds.cpp
-@@ -0,0 +1,68 @@
-+///////////////////////////////////////////////////////////////////////////////
-+//
-+// Copyright (c) 2015 Microsoft Corporation. All rights reserved.
-+//
-+// This code is licensed under the MIT License (MIT).
-+//
-+// THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+// IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+// FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-+// AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-+// LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-+// OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-+// THE SOFTWARE.
-+//
-+///////////////////////////////////////////////////////////////////////////////
-+
-+#ifdef __GNUC__
-+#pragma GCC diagnostic warning "-Warray-bounds"
-+#endif // __GNUC__
-+
-+#include <gtest/gtest.h>
-+
-+#include <gsl/multi_span> // for gsl::multi_span
-+
-+namespace gsl
-+{
-+struct fail_fast;
-+} // namespace gsl
-+
-+namespace
-+{
-+static constexpr char deathstring[] = "Expected Death";
-+} // namespace
-+
-+TEST(array_bounds, subspan_from_multi_span_test)
-+{
-+ int arr[5] = {1, 2, 3, 4, 5};
-+ gsl::multi_span<int> av = arr;
-+
-+ std::set_terminate([] {
-+ std::cerr << "Expected Death. subspan";
-+ std::abort();
-+ });
-+
-+ EXPECT_DEATH(av.subspan(6).length(), deathstring);
-+}
-+
-+TEST(array_bounds, strided_span_bounds_from_strided_span_tests)
-+{
-+ int arr[] = {0, 1, 2, 3};
-+ gsl::multi_span<int> av(arr);
-+
-+ std::set_terminate([] {
-+ std::cerr << "Expected Death. strided_span_bounds";
-+ std::abort();
-+ });
-+
-+ // incorrect sections
-+ EXPECT_DEATH(av.section(0, 0)[0], deathstring);
-+ EXPECT_DEATH(av.section(1, 0)[0], deathstring);
-+ EXPECT_DEATH(av.section(1, 1)[1], deathstring);
-+
-+ EXPECT_DEATH(av.section(2, 5), deathstring);
-+ EXPECT_DEATH(av.section(5, 2), deathstring);
-+ EXPECT_DEATH(av.section(5, 0), deathstring);
-+ EXPECT_DEATH(av.section(0, 5), deathstring);
-+ EXPECT_DEATH(av.section(5, 5), deathstring);
-+}
---- a/tests/multi_span_tests.cpp
-+++ b/tests/multi_span_tests.cpp
-@@ -1042,10 +1042,6 @@ TEST(multi_span_test, subspan)
- EXPECT_TRUE(av.subspan(1).length() == 4);
- EXPECT_TRUE(av.subspan(4).length() == 1);
- EXPECT_TRUE(av.subspan(5).length() == 0);
-- // Disabled test instead of fixing since multi_span is deprecated. (PR#835)
--#if !(defined(__GNUC__) && __GNUC__ == 8)
-- EXPECT_DEATH(av.subspan(6).length(), deathstring);
--#endif
- auto av2 = av.subspan(1);
- for (int i = 0; i < 4; ++i) EXPECT_TRUE(av2[i] == i + 2);
- }
---- a/tests/strided_span_tests.cpp
-+++ b/tests/strided_span_tests.cpp
-@@ -403,20 +403,6 @@ TEST(strided_span_tests, strided_span_bo
- });
-
- {
-- // incorrect sections
--
-- EXPECT_DEATH(av.section(0, 0)[0], deathstring);
-- EXPECT_DEATH(av.section(1, 0)[0], deathstring);
-- EXPECT_DEATH(av.section(1, 1)[1], deathstring);
--
-- EXPECT_DEATH(av.section(2, 5), deathstring);
-- EXPECT_DEATH(av.section(5, 2), deathstring);
-- EXPECT_DEATH(av.section(5, 0), deathstring);
-- EXPECT_DEATH(av.section(0, 5), deathstring);
-- EXPECT_DEATH(av.section(5, 5), deathstring);
-- }
--
-- {
- // zero stride
- strided_span<int, 1> sav{av, {{4}, {}}};
- EXPECT_TRUE(sav[0] == 0);
diff --git a/gnu/packages/patches/libtommath-integer-overflow.patch b/gnu/packages/patches/libtommath-integer-overflow.patch
new file mode 100644
index 0000000000..5241726775
--- /dev/null
+++ b/gnu/packages/patches/libtommath-integer-overflow.patch
@@ -0,0 +1,140 @@
+This patch is from upstream:
+https://github.com/libtom/libtommath/pull/546
+
+From beba892bc0d4e4ded4d667ab1d2a94f4d75109a9 Mon Sep 17 00:00:00 2001
+From: czurnieden <czurnieden@gmx.de>
+Date: Tue, 9 May 2023 17:17:12 +0200
+Subject: [PATCH] Fix possible integer overflow
+
+---
+ bn_mp_2expt.c | 4 ++++
+ bn_mp_grow.c | 4 ++++
+ bn_mp_init_size.c | 5 +++++
+ bn_mp_mul_2d.c | 4 ++++
+ bn_s_mp_mul_digs.c | 4 ++++
+ bn_s_mp_mul_digs_fast.c | 4 ++++
+ bn_s_mp_mul_high_digs.c | 4 ++++
+ bn_s_mp_mul_high_digs_fast.c | 4 ++++
+ 8 files changed, 33 insertions(+)
+
+diff --git a/bn_mp_2expt.c b/bn_mp_2expt.c
+index 0ae3df1bf..23de0c3c5 100644
+--- a/bn_mp_2expt.c
++++ b/bn_mp_2expt.c
+@@ -12,6 +12,10 @@ mp_err mp_2expt(mp_int *a, int b)
+ {
+ mp_err err;
+
++ if (b < 0) {
++ return MP_VAL;
++ }
++
+ /* zero a as per default */
+ mp_zero(a);
+
+diff --git a/bn_mp_grow.c b/bn_mp_grow.c
+index 9e904c547..2b1682651 100644
+--- a/bn_mp_grow.c
++++ b/bn_mp_grow.c
+@@ -9,6 +9,10 @@ mp_err mp_grow(mp_int *a, int size)
+ int i;
+ mp_digit *tmp;
+
++ if (size < 0) {
++ return MP_VAL;
++ }
++
+ /* if the alloc size is smaller alloc more ram */
+ if (a->alloc < size) {
+ /* reallocate the array a->dp
+diff --git a/bn_mp_init_size.c b/bn_mp_init_size.c
+index d62268721..99573833f 100644
+--- a/bn_mp_init_size.c
++++ b/bn_mp_init_size.c
+@@ -6,6 +6,11 @@
+ /* init an mp_init for a given size */
+ mp_err mp_init_size(mp_int *a, int size)
+ {
++
++ if (size < 0) {
++ return MP_VAL;
++ }
++
+ size = MP_MAX(MP_MIN_PREC, size);
+
+ /* alloc mem */
+diff --git a/bn_mp_mul_2d.c b/bn_mp_mul_2d.c
+index 87354de20..bfeaf2eb2 100644
+--- a/bn_mp_mul_2d.c
++++ b/bn_mp_mul_2d.c
+@@ -9,6 +9,10 @@ mp_err mp_mul_2d(const mp_int *a, int b, mp_int *c)
+ mp_digit d;
+ mp_err err;
+
++ if (b < 0) {
++ return MP_VAL;
++ }
++
+ /* copy */
+ if (a != c) {
+ if ((err = mp_copy(a, c)) != MP_OKAY) {
+diff --git a/bn_s_mp_mul_digs.c b/bn_s_mp_mul_digs.c
+index 64509d4cb..3682b4980 100644
+--- a/bn_s_mp_mul_digs.c
++++ b/bn_s_mp_mul_digs.c
+@@ -16,6 +16,10 @@ mp_err s_mp_mul_digs(const mp_int *a, const mp_int *b, mp_int *c, int digs)
+ mp_word r;
+ mp_digit tmpx, *tmpt, *tmpy;
+
++ if (digs < 0) {
++ return MP_VAL;
++ }
++
+ /* can we use the fast multiplier? */
+ if ((digs < MP_WARRAY) &&
+ (MP_MIN(a->used, b->used) < MP_MAXFAST)) {
+diff --git a/bn_s_mp_mul_digs_fast.c b/bn_s_mp_mul_digs_fast.c
+index b2a287b02..3c4176a87 100644
+--- a/bn_s_mp_mul_digs_fast.c
++++ b/bn_s_mp_mul_digs_fast.c
+@@ -26,6 +26,10 @@ mp_err s_mp_mul_digs_fast(const mp_int *a, const mp_int *b, mp_int *c, int digs)
+ mp_digit W[MP_WARRAY];
+ mp_word _W;
+
++ if (digs < 0) {
++ return MP_VAL;
++ }
++
+ /* grow the destination as required */
+ if (c->alloc < digs) {
+ if ((err = mp_grow(c, digs)) != MP_OKAY) {
+diff --git a/bn_s_mp_mul_high_digs.c b/bn_s_mp_mul_high_digs.c
+index 2bb2a5098..c9dd355f8 100644
+--- a/bn_s_mp_mul_high_digs.c
++++ b/bn_s_mp_mul_high_digs.c
+@@ -15,6 +15,10 @@ mp_err s_mp_mul_high_digs(const mp_int *a, const mp_int *b, mp_int *c, int digs)
+ mp_word r;
+ mp_digit tmpx, *tmpt, *tmpy;
+
++ if (digs < 0) {
++ return MP_VAL;
++ }
++
+ /* can we use the fast multiplier? */
+ if (MP_HAS(S_MP_MUL_HIGH_DIGS_FAST)
+ && ((a->used + b->used + 1) < MP_WARRAY)
+diff --git a/bn_s_mp_mul_high_digs_fast.c b/bn_s_mp_mul_high_digs_fast.c
+index a2c4fb692..4ce7f590c 100644
+--- a/bn_s_mp_mul_high_digs_fast.c
++++ b/bn_s_mp_mul_high_digs_fast.c
+@@ -19,6 +19,10 @@ mp_err s_mp_mul_high_digs_fast(const mp_int *a, const mp_int *b, mp_int *c, int
+ mp_digit W[MP_WARRAY];
+ mp_word _W;
+
++ if (digs < 0) {
++ return MP_VAL;
++ }
++
+ /* grow the destination as required */
+ pa = a->used + b->used;
+ if (c->alloc < pa) {
diff --git a/gnu/packages/patches/python-docrepr-fix-tests.patch b/gnu/packages/patches/python-docrepr-fix-tests.patch
new file mode 100644
index 0000000000..a209921025
--- /dev/null
+++ b/gnu/packages/patches/python-docrepr-fix-tests.patch
@@ -0,0 +1,16 @@
+Fixes the errors with use of asyncio in docrepr/tests/test_output.py:
+
+> await compare_screenshots(test_id, url)
+E TypeError: 'coroutine' object is not callable
+
+--- a/conftest.py
++++ b/conftest.py
+@@ -65,7 +65,7 @@ def _open_browser(url):
+
+
+ @pytest.fixture
+-async def compare_screenshots(request):
++def compare_screenshots(request):
+ """Run visual regression test on the output."""
+ async def _compare_screenshots(test_id, url):
+ if (request.config.getoption(COMPARE_SCREENSHOTS_OPTION) or
diff --git a/gnu/packages/patches/python-ipython-documentation-chars.patch b/gnu/packages/patches/python-ipython-documentation-chars.patch
deleted file mode 100644
index a52c54f513..0000000000
--- a/gnu/packages/patches/python-ipython-documentation-chars.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Avoid LaTeX errors due to non-printable characters.
-Submitted upstream: https://github.com/ipython/ipython/pull/13640
-
-diff --git a/IPython/utils/coloransi.py b/IPython/utils/coloransi.py
-index e33142180..9300b0108 100644
---- a/IPython/utils/coloransi.py
-+++ b/IPython/utils/coloransi.py
-@@ -74,8 +74,8 @@ class TermColors:
- class InputTermColors:
- """Color escape sequences for input prompts.
-
-- This class is similar to TermColors, but the escapes are wrapped in \001
-- and \002 so that readline can properly know the length of each line and
-+ This class is similar to TermColors, but the escapes are wrapped in \\001
-+ and \\002 so that readline can properly know the length of each line and
- can wrap lines accordingly. Use this class for any colored text which
- needs to be used in input prompts, such as in calls to raw_input().
-
diff --git a/gnu/packages/patches/python-ipython-documentation-repro.patch b/gnu/packages/patches/python-ipython-documentation-repro.patch
deleted file mode 100644
index d6a6e9c3fd..0000000000
--- a/gnu/packages/patches/python-ipython-documentation-repro.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Fix non-reproducibilities caused by time-dependent procedures.
-Submitted upstream: https://github.com/ipython/ipython/pull/13640
-
-diff --git a/IPython/sphinxext/ipython_directive.py b/IPython/sphinxext/ipython_directive.py
-index 18bdfcae9..2c665ac87 100644
---- a/IPython/sphinxext/ipython_directive.py
-+++ b/IPython/sphinxext/ipython_directive.py
-@@ -19,7 +19,7 @@
- In [1]: 1+1
-
- In [1]: import datetime
-- ...: datetime.datetime.now()
-+ ...: datetime.date.fromisoformat('2022-02-22')
-
- It supports IPython construct that plain
- Python does not understand (like magics):
-@@ -28,7 +28,7 @@
-
- In [0]: import time
-
-- In [0]: %timeit time.sleep(0.05)
-+ In [0]: %pdoc time
-
- This will also support top-level async when using IPython 7.0+
-
diff --git a/gnu/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch b/gnu/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch
index 3c062cbd9a..a603bc9d72 100644
--- a/gnu/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch
+++ b/gnu/packages/patches/telegram-desktop-allow-disable-libtgvoip.patch
@@ -1,4 +1,4 @@
-From 4d1a8351ee82728912fcf7ad0070049b2910c393 Mon Sep 17 00:00:00 2001
+From 322d2c452bf1a4df7b9fe161d4991a347043550c Mon Sep 17 00:00:00 2001
From: Klemens Nanni <klemens@posteo.de>
Date: Wed, 2 Mar 2022 01:07:48 +0100
Subject: [PATCH] Introduce TDESKTOP_DISABLE_LEGACY_TGVOIP
@@ -19,10 +19,10 @@ and telegram desktop/mobile versions without problems.
4 files changed, 21 insertions(+), 3 deletions(-)
diff --git a/Telegram/CMakeLists.txt b/Telegram/CMakeLists.txt
-index fb2bf370f..5d9578f2d 100644
+index 008c71b15..291305909 100644
--- a/Telegram/CMakeLists.txt
+++ b/Telegram/CMakeLists.txt
-@@ -28,7 +28,9 @@ get_filename_component(res_loc Resources REALPATH)
+@@ -26,7 +26,9 @@ get_filename_component(res_loc Resources REALPATH)
include(cmake/telegram_options.cmake)
include(cmake/lib_ffmpeg.cmake)
include(cmake/lib_stripe.cmake)
@@ -33,7 +33,7 @@ index fb2bf370f..5d9578f2d 100644
include(cmake/lib_tgcalls.cmake)
include(cmake/td_export.cmake)
include(cmake/td_mtproto.cmake)
-@@ -52,9 +54,7 @@ target_prepare_qrc(Telegram)
+@@ -49,9 +51,7 @@ set_target_properties(Telegram PROPERTIES AUTOMOC ON)
target_link_libraries(Telegram
PRIVATE
@@ -44,7 +44,7 @@ index fb2bf370f..5d9578f2d 100644
# Order in this list defines the order of include paths in command line.
# We need to place desktop-app::external_minizip this early to have its
diff --git a/Telegram/SourceFiles/calls/calls_call.cpp b/Telegram/SourceFiles/calls/calls_call.cpp
-index 6894d5d90..cd03620e7 100644
+index 5fe9ac677..bebf48e70 100644
--- a/Telegram/SourceFiles/calls/calls_call.cpp
+++ b/Telegram/SourceFiles/calls/calls_call.cpp
@@ -39,8 +39,10 @@ class InstanceImpl;
@@ -68,7 +68,7 @@ index 6894d5d90..cd03620e7 100644
[[nodiscard]] base::flat_set<int64> CollectEndpointIds(
const QVector<MTPPhoneConnection> &list) {
-@@ -1322,7 +1326,9 @@ Call::~Call() {
+@@ -1332,7 +1336,9 @@ Call::~Call() {
}
void UpdateConfig(const std::string &data) {
@@ -79,10 +79,10 @@ index 6894d5d90..cd03620e7 100644
} // namespace Calls
diff --git a/Telegram/cmake/lib_tgcalls.cmake b/Telegram/cmake/lib_tgcalls.cmake
-index 34a5ba418..8a784be2c 100644
+index 94cfdb856..9ac4fe479 100644
--- a/Telegram/cmake/lib_tgcalls.cmake
+++ b/Telegram/cmake/lib_tgcalls.cmake
-@@ -267,6 +267,10 @@ PRIVATE
+@@ -268,6 +268,10 @@ PRIVATE
${tgcalls_loc}
)
@@ -94,7 +94,7 @@ index 34a5ba418..8a784be2c 100644
init_target(lib_tgcalls_legacy)
diff --git a/Telegram/cmake/telegram_options.cmake b/Telegram/cmake/telegram_options.cmake
-index 1c3c25431..033f2bc95 100644
+index a5a6d9405..2eb9953f2 100644
--- a/Telegram/cmake/telegram_options.cmake
+++ b/Telegram/cmake/telegram_options.cmake
@@ -4,7 +4,9 @@
@@ -107,7 +107,7 @@ index 1c3c25431..033f2bc95 100644
set(TDESKTOP_API_ID "0" CACHE STRING "Provide 'api_id' for the Telegram API access.")
set(TDESKTOP_API_HASH "" CACHE STRING "Provide 'api_hash' for the Telegram API access.")
-@@ -40,6 +42,12 @@ if (TDESKTOP_API_ID STREQUAL "0" OR TDESKTOP_API_HASH STREQUAL "")
+@@ -36,6 +38,12 @@ if (TDESKTOP_API_ID STREQUAL "0" OR TDESKTOP_API_HASH STREQUAL "")
" ")
endif()
@@ -117,9 +117,9 @@ index 1c3c25431..033f2bc95 100644
+ target_link_libraries(Telegram PRIVATE tdesktop::lib_tgcalls_legacy tdesktop::lib_tgvoip)
+endif()
+
- if (DESKTOP_APP_DISABLE_SPELLCHECK)
- target_compile_definitions(Telegram PRIVATE TDESKTOP_DISABLE_SPELLCHECK)
- else()
+ if (DESKTOP_APP_DISABLE_AUTOUPDATE)
+ target_compile_definitions(Telegram PRIVATE TDESKTOP_DISABLE_AUTOUPDATE)
+ endif()
--
-2.37.3
+2.39.2
diff --git a/gnu/packages/patches/webrtc-for-telegram-desktop-fix-gcc12-cstdint.patch b/gnu/packages/patches/webrtc-for-telegram-desktop-fix-gcc12-cstdint.patch
deleted file mode 100644
index f1fd29d0d3..0000000000
--- a/gnu/packages/patches/webrtc-for-telegram-desktop-fix-gcc12-cstdint.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 86d2bcd7afb8706663d29e30f65863de5a626142 Mon Sep 17 00:00:00 2001
-From: Xiretza <xiretza@xiretza.xyz>
-Date: Sun, 15 May 2022 12:47:41 +0200
-Subject: [PATCH] fix(h265_pps_parser): fix missing cstdint include
-
----
- src/common_video/h265/h265_pps_parser.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/common_video/h265/h265_pps_parser.h b/src/common_video/h265/h265_pps_parser.h
-index 28c95ea9..c180b1b9 100644
---- a/src/common_video/h265/h265_pps_parser.h
-+++ b/src/common_video/h265/h265_pps_parser.h
-@@ -12,6 +12,7 @@
- #define COMMON_VIDEO_H265_PPS_PARSER_H_
-
- #include "absl/types/optional.h"
-+#include <cstdint>
-
- namespace rtc {
- class BitBuffer;