aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/lcalc-using-namespace-std.patch
diff options
context:
space:
mode:
authorvicvbcun <guix@ikherbers.com>2022-08-08 17:45:40 +0200
committerAndreas Enge <andreas@enge.fr>2022-08-12 10:21:00 +0200
commitd5a641dc2e28c0c944d5c4769d8171f79a187541 (patch)
tree888b11fdfdae14f07e38e55eac64cfb1724b3f15 /gnu/packages/patches/lcalc-using-namespace-std.patch
parent2e821717d34a24fec2422913f0c4fb975b86b0f4 (diff)
downloadguix-d5a641dc2e28c0c944d5c4769d8171f79a187541.tar
guix-d5a641dc2e28c0c944d5c4769d8171f79a187541.tar.gz
gnu: lcalc: Update to 2.0.5.
* gnu/packages/sagemath.scm (lcalc): Update to 2.0.5. * gnu/packages/patches/lcalc-default-parameters-1.patch, gnu/packages/patches/lcalc-default-parameters-2.patch, gnu/packages/patches/lcalc-lcommon-h.patch, gnu/packages/patches/lcalc-using-namespace-std.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Unregister files. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/patches/lcalc-using-namespace-std.patch')
-rw-r--r--gnu/packages/patches/lcalc-using-namespace-std.patch43
1 files changed, 0 insertions, 43 deletions
diff --git a/gnu/packages/patches/lcalc-using-namespace-std.patch b/gnu/packages/patches/lcalc-using-namespace-std.patch
deleted file mode 100644
index 6e0075fdc8..0000000000
--- a/gnu/packages/patches/lcalc-using-namespace-std.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Patch taken from the Sage packaging system.
-
-diff --git a/include/Lcommon.h b/include/Lcommon.h
-index 1b3be43..bf40532 100644
---- a/include/Lcommon.h
-+++ b/include/Lcommon.h
-@@ -48,7 +48,7 @@ const bool outputSeries=true; // Whether to output the coefficients or just th
-
- // Loop i from m to n
- // Useful in tidying up most for loops
--#define loop(i,m,n) for(typeof(m) i=(m); i!=(n); i++)
-+#define loop(i,m,n) for(auto i=(m); i!=(n); i++)
-
- // A class for calculations involving polynomials of small degree
- // Not efficient enough for huge polynomials
-diff --git a/include/Lcommon_ld.h b/include/Lcommon_ld.h
-index 86ae4df..33c560c 100644
---- a/include/Lcommon_ld.h
-+++ b/include/Lcommon_ld.h
-@@ -53,7 +53,7 @@ const bool outputSeries=true; // Whether to output the coefficients or just th
-
- // Loop i from m to n
- // Useful in tidying up most for loops
--#define loop(i,m,n) for(typeof(m) i=(m); i!=(n); i++)
-+#define loop(i,m,n) for(auto i=(m); i!=(n); i++)
-
- // A class for calculations involving polynomials of small degree
- // Not efficient enough for huge polynomials
-diff --git a/include/Lglobals.h b/include/Lglobals.h
-index 60002e4..ca2606c 100644
---- a/include/Lglobals.h
-+++ b/include/Lglobals.h
-@@ -24,9 +24,9 @@
- #ifndef Lglobals_H
- #define Lglobals_H
-
-+#include <valarray>
- using namespace std;
-
--#include <valarray>
- #ifdef USE_MPFR
- #include "Lgmpfrxx.h"
- typedef mpfr_class Double;