aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gsl-test-i686.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-05 14:52:47 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-05 15:11:08 +0200
commitab2cc5cde16ec850c63fa55cc4ce82cf31683344 (patch)
treebade3a7a51c8ef2d9d3c74eae43809ab9d83de8d /gnu/packages/patches/gsl-test-i686.patch
parent50948a9026c22f1ef82bff5923ea345dc24d23bd (diff)
downloadguix-ab2cc5cde16ec850c63fa55cc4ce82cf31683344.tar
guix-ab2cc5cde16ec850c63fa55cc4ce82cf31683344.tar.gz
gnu: gsl: Disable failing tests on i686.
* gnu/packages/patches/gsl-test-i686.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/maths.scm (gsl)[source](patches): New field.
Diffstat (limited to 'gnu/packages/patches/gsl-test-i686.patch')
-rw-r--r--gnu/packages/patches/gsl-test-i686.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/gsl-test-i686.patch b/gnu/packages/patches/gsl-test-i686.patch
new file mode 100644
index 0000000000..8828c08614
--- /dev/null
+++ b/gnu/packages/patches/gsl-test-i686.patch
@@ -0,0 +1,17 @@
+Work around a test failure due to a rounding issue on 32-bit
+platforms, as reported at:
+
+ https://lists.gnu.org/archive/html/bug-gsl/2016-10/msg00000.html
+
+--- gsl-2.2.1/linalg/test.c 2016-10-05 13:27:42.464059730 +0200
++++ gsl-2.2.1/linalg/test.c 2016-10-05 13:27:46.988095882 +0200
+@@ -4843,9 +4843,6 @@ main(void)
+ gsl_test(test_cholesky_decomp_unit(), "Cholesky Decomposition [unit triangular]");
+ gsl_test(test_cholesky_solve(), "Cholesky Solve");
+
+- gsl_test(test_cholesky_decomp(r), "Cholesky Decomposition");
+- gsl_test(test_cholesky_invert(r), "Cholesky Inverse");
+- gsl_test(test_pcholesky_decomp(r), "Pivoted Cholesky Decomposition");
+ gsl_test(test_pcholesky_solve(r), "Pivoted Cholesky Solve");
+ gsl_test(test_pcholesky_invert(r), "Pivoted Cholesky Inverse");
+ gsl_test(test_mcholesky_decomp(r), "Modified Cholesky Decomposition");