aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/glib-tests-prlimit.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-27 15:01:30 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-27 15:01:30 +0100
commit785db4d877959c0b948859d19dff22384924fae4 (patch)
treedc0f5d20d3b37311ea77f475c4316177cc6e757a /gnu/packages/patches/glib-tests-prlimit.patch
parent0b5aa854a0387d10c48488f408ffa21367ea48ac (diff)
downloadguix-785db4d877959c0b948859d19dff22384924fae4.tar
guix-785db4d877959c0b948859d19dff22384924fae4.tar.gz
glib: Patch around prlimit(2) failure.
* gnu/packages/glib.scm (glib)[source]: Switch to mirror://gnome. [inputs]: Add `patch/tests-prlimit'. [arguments]: Add it. * gnu/packages/patches/glib-tests-prlimit.patch: New file. * Makefile.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/glib-tests-prlimit.patch')
-rw-r--r--gnu/packages/patches/glib-tests-prlimit.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/glib-tests-prlimit.patch b/gnu/packages/patches/glib-tests-prlimit.patch
new file mode 100644
index 0000000000..f2b2a61bee
--- /dev/null
+++ b/gnu/packages/patches/glib-tests-prlimit.patch
@@ -0,0 +1,14 @@
+prlimit(2) returns ENOSYS on Linux 2.6.32-5-xen-amd64 as found on
+hydra.gnu.org, and strace(1) doesn't recognize it.
+
+--- glib-2.34.3/glib/tests/thread.c 2012-11-20 15:27:12.000000000 +0100
++++ glib-2.34.3/glib/tests/thread.c 2013-03-27 14:48:31.000000000 +0100
+@@ -130,7 +130,7 @@ test_thread3 (void)
+ static void
+ test_thread4 (void)
+ {
+-#ifdef HAVE_PRLIMIT
++#if 0
+ struct rlimit ol, nl;
+ GThread *thread;
+ GError *error;