aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/doxygen-gcc-ice.patch
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-29 22:51:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-29 22:51:23 +0200
commitf1728d43460e63b106dd446e70001d8e100eaf6d (patch)
tree9d211fabf9e200743be49e25d108d58ed88d2f60 /gnu/packages/patches/doxygen-gcc-ice.patch
parentcda7f4bc8ecf331d623c7d37b01931a46830c648 (diff)
parent373cc3b74a6ad33fddf75c2d773a97b1775bda8e (diff)
downloadguix-f1728d43460e63b106dd446e70001d8e100eaf6d.tar
guix-f1728d43460e63b106dd446e70001d8e100eaf6d.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/doxygen-gcc-ice.patch')
-rw-r--r--gnu/packages/patches/doxygen-gcc-ice.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/doxygen-gcc-ice.patch b/gnu/packages/patches/doxygen-gcc-ice.patch
new file mode 100644
index 0000000000..fbfedcb7ab
--- /dev/null
+++ b/gnu/packages/patches/doxygen-gcc-ice.patch
@@ -0,0 +1,25 @@
+Work around this GCC ICE: <https://bugs.gnu.org/31708>. It shows up
+only when doing native compiles on armhf-linux.
+
+Yes it's a terrible patch, but it does the job.
+
+--- doxygen-1.8.13/qtools/qutfcodec.cpp 1970-01-01 01:00:00.000000000 +0100
++++ doxygen-1.8.13/qtools/qutfcodec.cpp 2018-06-08 14:14:29.614009929 +0200
+@@ -189,7 +189,7 @@ int QUtf16Codec::heuristicContentMatch(c
+ }
+
+
+-
++volatile const void *bomPointer = &QChar::byteOrderMark;
+
+ class QUtf16Encoder : public QTextEncoder {
+ bool headerdone;
+@@ -209,7 +209,7 @@ public:
+ headerdone = TRUE;
+ len_in_out = (1+uc.length())*(int)sizeof(QChar);
+ QCString d(len_in_out);
+- memcpy(d.rawData(),&QChar::byteOrderMark,sizeof(QChar));
++ memcpy(d.rawData(),(void *)bomPointer,sizeof(QChar));
+ memcpy(d.rawData()+sizeof(QChar),uc.unicode(),uc.length()*sizeof(QChar));
+ return d;
+ }