aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/cmake-fix-tests.patch
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-13 17:00:18 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-13 17:00:18 +0200
commit6eac909b459301912becb854c112532ee3fd7cc3 (patch)
tree6a61cb55d36c00fc6c5eb4c5fbbdf43a9d9c3c4f /gnu/packages/patches/cmake-fix-tests.patch
parent487da565703c34ae3b57977b0b6e31dada77a129 (diff)
downloadguix-6eac909b459301912becb854c112532ee3fd7cc3.tar
guix-6eac909b459301912becb854c112532ee3fd7cc3.tar.gz
gnu: cmake: Update patch to work with new system.
* gnu/packages/patches/cmake-fix-tests.patch: Update to work with -p1. * gnu/packages/cmake.scm (cmake): Drop patch flag -p0.
Diffstat (limited to 'gnu/packages/patches/cmake-fix-tests.patch')
-rw-r--r--gnu/packages/patches/cmake-fix-tests.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/patches/cmake-fix-tests.patch b/gnu/packages/patches/cmake-fix-tests.patch
index ae28ca336b..5327f3749a 100644
--- a/gnu/packages/patches/cmake-fix-tests.patch
+++ b/gnu/packages/patches/cmake-fix-tests.patch
@@ -1,5 +1,5 @@
---- Tests/CMakeLists.txt 2013-03-20 22:57:13.000000000 +0100
-+++ Tests/CMakeLists.txt 2013-03-20 22:58:02.000000000 +0100
+--- a/Tests/CMakeLists.txt 2013-03-20 22:57:13.000000000 +0100
++++ b/Tests/CMakeLists.txt 2013-03-20 22:58:02.000000000 +0100
@@ -1706,16 +1706,17 @@
PASS_REGULAR_EXPRESSION "Could not find executable"
FAIL_REGULAR_EXPRESSION "SegFault")
@@ -28,8 +28,8 @@
configure_file(
"${CMake_SOURCE_DIR}/Tests/CTestTestConfigFileInBuildDir/test1.cmake.in"
---- Utilities/cmcurl/CMakeLists.txt 2013-03-20 22:57:13.000000000 +0100
-+++ Utilities/cmcurl/CMakeLists.txt 2013-03-20 23:08:41.000000000 +0100
+--- a/Utilities/cmcurl/CMakeLists.txt 2013-03-20 22:57:13.000000000 +0100
++++ b/Utilities/cmcurl/CMakeLists.txt 2013-03-20 23:08:41.000000000 +0100
@@ -729,8 +729,9 @@
ADD_EXECUTABLE(LIBCURL Testing/curltest.c)
TARGET_LINK_LIBRARIES(LIBCURL cmcurl ${CMAKE_DL_LIBS})