aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:00 +0200
commitfa1cd5b31fc2fce77beb4bb4eac2fdbc4cae1071 (patch)
treeff44104c3923b35dfe972557e30d9450326014c0 /gnu/packages/password-utils.scm
parent55c7b83b5a2aa826ff42b7ea94b4db053d94a1c7 (diff)
downloadguix-fa1cd5b31fc2fce77beb4bb4eac2fdbc4cae1071.tar
guix-fa1cd5b31fc2fce77beb4bb4eac2fdbc4cae1071.tar.gz
gnu: pass-age: Add age-keygen to inputs.
* gnu/packages/password-utils.scm (pass-age)[inputs]: Add age-keygen. [arguments]: Wrap with it.
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 404f588502..7293cb7c1f 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -630,6 +630,7 @@ through the pass command.")
,(map dirname
(map (cut search-input-file inputs <>)
(list "bin/age"
+ "bin/age-keygen"
"bin/getopt"
"bin/git"
"bin/pkill"
@@ -643,7 +644,7 @@ through the pass command.")
("src/completion/pass.zsh-completion"
"/share/zsh/site-functions/"))))
(inputs
- (list age git procps qrencode sed tree util-linux))
+ (list age age-keygen git procps qrencode sed tree util-linux))
(home-page "https://github.com/FiloSottile/passage")
(synopsis "Encrypted password manager")
(description "This package provides an encrypted password manager, forked