aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:33 +0200
commitd618307725b8b098f6659d4213501c38f5667cf6 (patch)
tree0b462cbffe4755f5a35de460fe0cb1cc9d52022e /gnu/packages/password-utils.scm
parent07232e6b17247495135fa3285e9eb2bd659bec94 (diff)
downloadguix-d618307725b8b098f6659d4213501c38f5667cf6.tar
guix-d618307725b8b098f6659d4213501c38f5667cf6.tar.gz
gnu: Add go-filippo-io-age.
* gnu/packages/password-utils.scm (age): Move from here… * gnu/packages/golang.scm (age): …to here, and inherit from… (go-filippo-io-age): …this new source-only package variable.
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 9d5fd79c58..404f588502 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -116,35 +116,6 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages xml))
-(define-public age
- (package
- (name "age")
- (version "1.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/FiloSottile/age")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "19fz68n262kvg2ssw4r6nik30zk6g6cy7rdi0fm05czwigqrdz1i"))))
- (build-system go-build-system)
- (arguments `(#:import-path "filippo.io/age"))
- (inputs
- (list go-golang-org-x-sys
- go-golang-org-x-term
- go-golang-org-x-crypto
- go-filippo-io-edwards25519))
- (home-page "https://filippo.io/age")
- (synopsis "Secure file encryption tool, format, and Go library")
- (description
- "This package implements file encryption according to the
-@{age-encryption.org/v1, https://age-encryption.org/v1} specification.
-It features small explicit keys, no configuration options, and Unix-style
-composability.")
- (license license:bsd-3)))
-
(define-public pwgen
(package
(name "pwgen")