aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorflabbergasted <flabbergasted@nofog.net>2023-06-08 22:11:03 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-05 23:57:27 +0200
commitbbf6ef5b906cbc77136ef17ac550b21693eefb2d (patch)
treecdf2355ab979ac67f8060e16131535d70adaca6d /gnu/packages/password-utils.scm
parent07854c91d8a4a9c20e8391cc4d07715a4cc39f23 (diff)
downloadguix-bbf6ef5b906cbc77136ef17ac550b21693eefb2d.tar
guix-bbf6ef5b906cbc77136ef17ac550b21693eefb2d.tar.gz
gnu: Add passwdqc.
* gnu/packages/password-utils.scm (passwdqc): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 897f5b1bdd..508a929844 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -531,6 +531,45 @@ them out, at the source.")
random passwords that pass the checks.")
(license license:gpl2+)))
+(define-public passwdqc
+ (package
+ (name "passwdqc")
+ (version "2.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.openwall.com/passwdqc/passwdqc"
+ "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1aq40v5094bhnj86v4i2nmqkybmzzp20q7jb92jgc860cibm07zz"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests provided
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "DESTDIR=" #$output)
+ "BINDIR=/bin"
+ "DEVEL_LIBDIR=/lib"
+ "SHARED_LIBDIR_REL=."
+ "INCLUDEDIR=/include"
+ "MANDIR=/share/man"
+ (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ;no configure script
+ (inputs (list linux-pam))
+ (home-page "https://www.openwall.com/passwdqc/")
+ (synopsis
+ "Password/passphrase strength checking and policy enforcement toolset")
+ (description
+ "Passwdqc is a password/passphrase strength checking and policy
+enforcement toolset, including an optional PAM module, @code{pam_passwdqc},
+command-line programs (@command{pwqcheck}, @command{pwqfilter}, and
+@command{pwqgen}), and a library, @code{libpasswdqc}.")
+ (license (list license:bsd-3 ;manual pages
+ license:bsd-1)))) ;code
+
(define-public assword
(package
(name "assword")