aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/parallel.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-03-23 20:46:28 +0800
committerChristopher Baines <mail@cbaines.net>2024-03-25 20:44:40 +0000
commit46000846de292c25453b7afbb129c1931c118b8d (patch)
treeb27cfc36653ffd17893bedcfb53df7e05e66c89b /gnu/packages/parallel.scm
parent82fe02130e5bb09c4c2d6aa36071caa8ee973f09 (diff)
downloadguix-46000846de292c25453b7afbb129c1931c118b8d.tar
guix-46000846de292c25453b7afbb129c1931c118b8d.tar.gz
gnu: xe: Fix cross-compilation.
* gnu/packages/parallel.scm (xe): Fix cross-compilation. [arguments]: Use Gexp. Change-Id: I937acbba1cb5ba0f04976121f06d01789caed456 Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/parallel.scm')
-rw-r--r--gnu/packages/parallel.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index ddf4ad016b..b2a5648842 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2019-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -143,11 +144,11 @@ and they are executed on lists of files, hosts, users or other items.")
(base32 "1ijvf7q5pxk4rlj7p9q6fmpdqiwmc28gffkk6yg390k1a1z3msf9"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f
- #:make-flags (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" %output))
- #:phases (modify-phases %standard-phases
- (delete 'configure))))
+ (list #:tests? #f
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
(synopsis "Execute a command for every argument")
(description
"The xe utility constructs command lines from specified arguments,