aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2023-06-05 00:43:46 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-01 15:48:55 +0200
commit554d46882bc4443dcebbba5aac70b016537d0975 (patch)
tree19803624d1f7e548a5f598e5eb1e91d7fa2a546b /gnu/packages/package-management.scm
parent4236e24cb9e80201e42d13c9a70bd918299b12fa (diff)
downloadguix-554d46882bc4443dcebbba5aac70b016537d0975.tar
guix-554d46882bc4443dcebbba5aac70b016537d0975.tar.gz
gnu: nix: Update to 2.16.0.
* gnu/packages/package-management.scm (nix): Update to 2.16.0. [inputs]: Add nlohmann-json. [native-inputs]: Add rapidcheck. [arguments]<#:phases>: In phase "check", change the value of environment variable "NIX_STORE" to "/nix/store" temporarily. * gnu/packages/patches/nix-dont-build-html-doc.diff: Update. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm25
1 files changed, 20 insertions, 5 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index e3dba508f0..1bf3859a09 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -20,7 +20,7 @@
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
-;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022, 2023 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -56,6 +56,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages cmake)
#:use-module (gnu packages cpio)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
@@ -731,7 +732,7 @@ high-performance computing} clusters.")
(define-public nix
(package
(name "nix")
- (version "2.5.1")
+ (version "2.16.0")
(source
(origin
(method git-fetch)
@@ -740,7 +741,7 @@ high-performance computing} clusters.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1m8rmv8i6lg83pmalvjlq1fn8mcghn3ngjv3kw1kqsa45ymj5sqq"))
+ (base32 "0jizpci4zspqpqqy3n780m4wh8dzhfywaiz953xv70c7in810dra"))
(patches
(search-patches "nix-dont-build-html-doc.diff"))))
(build-system gnu-build-system)
@@ -757,7 +758,19 @@ high-performance computing} clusters.")
(apply invoke "make" "install"
(string-append "sysconfdir=" etc)
(string-append "profiledir=" etc "/profile.d")
- make-flags)))))))
+ make-flags))))
+ (replace 'check
+ (lambda args
+ ;; Some test expect environment variable NIX_STORE to be
+ ;; "/nix/store"
+ (let ((original-NIX_STORE (getenv "NIX_STORE")))
+ (dynamic-wind
+ (lambda ()
+ (setenv "NIX_STORE" "/nix/store"))
+ (lambda ()
+ (apply (assoc-ref %standard-phases 'check) args))
+ (lambda ()
+ (setenv "NIX_STORE" original-NIX_STORE)))))))))
(native-inputs
(list autoconf
autoconf-archive
@@ -767,7 +780,8 @@ high-performance computing} clusters.")
googletest
jq
libtool
- pkg-config))
+ pkg-config
+ rapidcheck))
(inputs
(append (list boost
brotli
@@ -779,6 +793,7 @@ high-performance computing} clusters.")
libseccomp
libsodium
lowdown
+ nlohmann-json
openssl
sqlite
xz