aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/opencl.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-10 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-09-10 02:00:00 +0200
commit3341b22f594398b3aa3ff930d99b74a78abd1a30 (patch)
tree30416ff29cdbaa8af1cb37a0b560635a5f3847d0 /gnu/packages/opencl.scm
parent213516f0baf92b6f50bd0c2e005625c0b3421a6f (diff)
downloadguix-3341b22f594398b3aa3ff930d99b74a78abd1a30.tar
guix-3341b22f594398b3aa3ff930d99b74a78abd1a30.tar.gz
gnu: Add ocl-icd.
* gnu/packages/opencl.scm (ocl-icd): New public variable.
Diffstat (limited to 'gnu/packages/opencl.scm')
-rw-r--r--gnu/packages/opencl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index caafa6beaf..7275dfb573 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -197,6 +197,31 @@ possible (known) properties of the OpenCL platform and devices available on
the system.")
(license license:cc0)))
+(define-public ocl-icd
+ (package
+ (name "ocl-icd")
+ (version "2.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OCL-dev/ocl-icd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y0lnxb6zlhfb5vxxib5n1vvxa4b23qc0j3lsih6yjz9j37mj7wz"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf automake libtool ruby))
+ (home-page "https://github.com/OCL-dev/ocl-icd")
+ (synopsis "Generic OpenCL @acronym{ICD, Installable Client Driver} loader")
+ (description
+ "This package provides an OpenCL @acronym{ICD, Installable Client Driver}
+loader. It maintains a YAML database of all known and guessed function pointers
+from vendor-specific drivers. It also delivers a skeleton of bindings to
+incorporate inside an OpenCL implementation to give it ICD functionalities.")
+ (license license:bsd-2)))
+
(define-public beignet
(package
(name "beignet")