aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/onc-rpc.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-03-17 20:15:15 +0000
committerChristopher Baines <mail@cbaines.net>2021-03-17 20:15:15 +0000
commitd7b4ccefa9452033dc8f6875ef40b108591ad5b4 (patch)
treeab14e81fc61dc87e24adb215338d13b2c7b58ca1 /gnu/packages/onc-rpc.scm
parentf4f677f2237915d64ca4eb4b1bb8e31ec61d0476 (diff)
downloadguix-d7b4ccefa9452033dc8f6875ef40b108591ad5b4.tar
guix-d7b4ccefa9452033dc8f6875ef40b108591ad5b4.tar.gz
gnu: libtirpc/hurd: Fix package source.
Amend the changes in 1a265842e634656411bc7304c4648273f174f65e to properly access the origin patches from libtirpc. I noticed this as guix weather didn't work for this package. * gnu/packages/onc-rpc.scm (libtirpc/hurd)[source]: Call origin-patches on (package-source libtirpc) rather than the libtirpc package.
Diffstat (limited to 'gnu/packages/onc-rpc.scm')
-rw-r--r--gnu/packages/onc-rpc.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/onc-rpc.scm b/gnu/packages/onc-rpc.scm
index c58bdb1dfc..3b29335d90 100644
--- a/gnu/packages/onc-rpc.scm
+++ b/gnu/packages/onc-rpc.scm
@@ -78,7 +78,7 @@ IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
(package/inherit libtirpc
(name "libtirpc-hurd")
(source (origin (inherit (package-source libtirpc))
- (patches (append (origin-patches libtirpc)
+ (patches (append (origin-patches (package-source libtirpc))
(search-patches "libtirpc-hurd.patch"
"libtirpc-hurd-client.patch")))))
(arguments