aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/onc-rpc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-07 17:33:02 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-07 17:35:58 +0300
commit92769ab2828b53ce41200e8beb8789a12863ee53 (patch)
tree476bca7dd7b3a85b50b52d3652d96e859a1e978e /gnu/packages/onc-rpc.scm
parent6757ee9d2bbdc3d064eacfc332d756105521166c (diff)
downloadguix-92769ab2828b53ce41200e8beb8789a12863ee53.tar
guix-92769ab2828b53ce41200e8beb8789a12863ee53.tar.gz
gnu: libtirpc: Fix CVE-2021-46828.
* gnu/packages/onc-rpc.scm (libtirpc)[replacement]: New field. (libtirpc/fixed): New variable. (libtirpc-hurd)[source]: Add patch. * gnu/packages/patches/libtirpc-CVE-2021-46828.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/onc-rpc.scm')
-rw-r--r--gnu/packages/onc-rpc.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/onc-rpc.scm b/gnu/packages/onc-rpc.scm
index f1cab94e08..873dc54c30 100644
--- a/gnu/packages/onc-rpc.scm
+++ b/gnu/packages/onc-rpc.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
(package
(name "libtirpc")
(version "1.3.1")
+ (replacement libtirpc/fixed)
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
@@ -74,7 +76,8 @@ IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
(package/inherit libtirpc
(name "libtirpc-hurd")
(source (origin (inherit (package-source libtirpc))
- (patches (search-patches "libtirpc-hurd.patch"))))
+ (patches (search-patches "libtirpc-hurd.patch"
+ "libtirpc-CVE-2021-46828.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments libtirpc)
((#:configure-flags flags ''())
@@ -83,6 +86,13 @@ IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
(assoc-ref %build-inputs "mit-krb5")
"/bin/krb5-config")))))))
+(define libtirpc/fixed
+ (package
+ (inherit libtirpc)
+ (source (origin
+ (inherit (package-source libtirpc))
+ (patches (search-patches "libtirpc-CVE-2021-46828.patch"))))))
+
(define-public rpcbind
(package
(name "rpcbind")