aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:01:21 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:10:36 +0100
commitd2ea723f8eda3e6e57ca75be4f57c31dec18a6fc (patch)
treeba875b25514ef96b1933628aa82dea8c07b50af4 /gnu/packages/ocaml.scm
parent47532ebc1e9fd00fa101b8a7f76f318daf7d46b4 (diff)
downloadguix-d2ea723f8eda3e6e57ca75be4f57c31dec18a6fc.tar
guix-d2ea723f8eda3e6e57ca75be4f57c31dec18a6fc.tar.gz
gnu: Remove ocaml4.07-ppx-optional.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-optional): Remove variable. (ocaml-ppx-optional)[properties]: Remove variant. Change-Id: Ie6aad28146cea0f5b48be78c68e7341307234e4a
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 631b7e2bf0..0c0a1d1765 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7257,8 +7257,7 @@ literal of the form 1.0v to conversion functions currently in scope.")
(arguments `(#:tests? #f)) ; No tests
(propagated-inputs
(list ocaml-base ocaml-migrate-parsetree ocaml-ppxlib))
- (properties `((upstream-name . "ppx_optional")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-optional))))
+ (properties `((upstream-name . "ppx_optional")))
(home-page "https://github.com/janestreet/ppx_optional")
(synopsis "Pattern matching on flat options")
(description
@@ -7266,17 +7265,6 @@ literal of the form 1.0v to conversion functions currently in scope.")
else expression.")
(license license:asl2.0)))
-(define-public ocaml4.07-ppx-optional
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-optional)
- (version "0.11.0")
- (source
- (janestreet-origin
- "ppx_optional" version
- "1z8z2bga95k2vksljljfglg10vygkjd24kn1b37sk4z3nmp47x0h"))
- (properties `((upstream-name . "ppx_optional"))))))
-
(define-public ocaml-ppx-optcomp
(package
(name "ocaml-ppx-optcomp")