aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:04:29 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:10:53 +0100
commitb3a0e3ea37d61f1e7fc529adb6eef62ddc89338d (patch)
tree62cc0394aee5cd11bbacd2c1091a0904db8bd265 /gnu/packages/ocaml.scm
parent5ecb3d4383b4b66248f5477e14baea217cfaea35 (diff)
downloadguix-b3a0e3ea37d61f1e7fc529adb6eef62ddc89338d.tar
guix-b3a0e3ea37d61f1e7fc529adb6eef62ddc89338d.tar.gz
gnu: Remove ocaml4.07-ppx-hash.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-hash): Remove variable. (ocaml-ppx-hash)[properties]: Remove variant. Change-Id: I38a4e5a4deb88398ae714b0671c9477551e7b6d9
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 1 insertions, 20 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ac2da9cead..bbcf97ccb0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6897,32 +6897,13 @@ currently provides SHA1, SHA256 and SHA512 hash functions.")
(propagated-inputs
(list ocaml-base ocaml-ppx-compare ocaml-ppx-sexp-conv
ocaml-migrate-parsetree ocaml-ppxlib))
- (properties `((upstream-name . "ppx_hash")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-hash))))
+ (properties `((upstream-name . "ppx_hash")))
(home-page "https://github.com/janestreet/ppx_hash")
(synopsis "Generation of hash functions from type expressions and definitions")
(description "This package is a collection of ppx rewriters that generate
hash functions from type exrpessions and definitions.")
(license license:asl2.0)))
-(define-public ocaml4.07-ppx-hash
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-hash)
- (name "ocaml-ppx-hash")
- (home-page "https://github.com/janestreet/ppx_hash")
- (version "0.11.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1p0ic6aijxlrdggpmycj12q3cy9xksbq2vq727215maz4snvlf5p"))))
- (properties `((upstream-name . "ppx_hash"))))))
-
(define-public ocaml-ppx-enumerate
(package
(name "ocaml-ppx-enumerate")