aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2024-01-10 08:43:28 +0100
committerJulien Lepiller <julien@lepiller.eu>2024-02-08 23:22:33 +0100
commitb2a71b868ce3fed5779eebc172c239307bf9a4bc (patch)
treef3b957a5c0695f42c298c05136a4089746d6d321 /gnu/packages/ocaml.scm
parent039cf0e35c4a6a2e76a908c7846f3dc431d34996 (diff)
downloadguix-b2a71b868ce3fed5779eebc172c239307bf9a4bc.tar
guix-b2a71b868ce3fed5779eebc172c239307bf9a4bc.tar.gz
gnu: Add dune-ordering.
* gnu/packages/ocaml.scm (dune-ordering): New variable. Change-Id: I78d81dfc2523b47bdca6430e2f9961cf39c7335a
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3a0c9c6da8..aaa9e23982 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2028,6 +2028,25 @@ defines its own algebra which some might find easier to work with and reason
about.")
(license license:expat)))
+(define-public dune-ordering
+ (package
+ (inherit dune)
+ (name "dune-ordering")
+ (source (origin
+ (inherit (package-source dune))
+ (modules '((guix build utils)))
+ (snippet
+ `(begin
+ (delete-file-recursively "vendor/pp")
+ (delete-file-recursively "vendor/csexp")))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:package "ordering"
+ ;; Tests have a cyclic dependency on stdune
+ #:tests? #f))
+ (synopsis "Dune element ordering")
+ (description "This library represents element ordering in OCaml.")))
+
(define-public ocaml-csexp
(package
(name "ocaml-csexp")