aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:52:55 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:13:57 +0100
commit4a7b5889237cf785efc6b1feb0acf1fe7622c776 (patch)
tree4ba13bde0881e6c376dc0d784d96da02421197a4 /gnu/packages/ocaml.scm
parente22e54aa0488189e76eaa308af01bc84b2bbb477 (diff)
downloadguix-4a7b5889237cf785efc6b1feb0acf1fe7622c776.tar
guix-4a7b5889237cf785efc6b1feb0acf1fe7622c776.tar.gz
gnu: Remove ocaml4.07-sexplib0.
* gnu/packages/ocaml.scm (ocaml4.07-sexplib0): Remove variable. (ocaml-sexplib0)[properties]: Remove variant. Change-Id: Ie370668adc446fc4c2b04206a6657380e5e09790
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 0 insertions, 13 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ed868ea1f9..f636ce0085 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5849,7 +5849,6 @@ exclusion algorithms are typical examples of such systems.")
"05m93g4m4jhj1v8pazg3s2ydcfymr3h4476yjhdca5fm4sn35bg8"))))
(build-system dune-build-system)
(arguments `(#:tests? #f)) ;no tests
- (properties `((ocaml4.07-variant . ,(delay ocaml4.07-sexplib0))))
(synopsis "Library containing the definition of S-expressions and some
base converters")
(description "Part of Jane Street's Core library The Core suite of
@@ -5857,18 +5856,6 @@ libraries is an industrial strength alternative to OCaml's standard library
that was developed by Jane Street, the largest industrial user of OCaml.")
(license license:expat)))
-(define-public ocaml4.07-sexplib0
- (package-with-ocaml4.07
- (package
- (inherit ocaml-sexplib0)
- (name "ocaml-sexplib0")
- (version "0.11.0")
- (source
- (janestreet-origin "sexplib0" version
- "1p06p2s7p9xsjn0z9qicniv1ai54d8sj11k8j633di2mm7jzxpin"))
- (arguments `(#:tests? #f)) ; no tests
- (properties '()))))
-
(define-public ocaml-parsexp
(package
(name "ocaml-parsexp")