aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:45:54 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:12:29 +0100
commit34063642500ff05d595a80993f584ba80c8caa12 (patch)
tree332bae009fca3782cf3ad8c25b9926c2af00344e /gnu/packages/ocaml.scm
parent937cae5bbe46b59c4546d86cd8faaf091d9ec5fd (diff)
downloadguix-34063642500ff05d595a80993f584ba80c8caa12.tar
guix-34063642500ff05d595a80993f584ba80c8caa12.tar.gz
gnu: Remove ocaml4.07-ppxlib.
* gnu/packages/ocaml.scm (ocaml4.07-ppxlib): Remove variable. (ocaml-ppxlib)[properties]: Remove variant. Change-Id: I6b19e7751d1c21549d261281ae400f90c8d88c6c
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm41
1 files changed, 0 insertions, 41 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7d4f63a7e3..a411bb78e0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6313,7 +6313,6 @@ the OCaml code.")
(list ocaml-stdio
ocaml-cinaps
ocaml-base))
- (properties `((ocaml4.07-variant . ,(delay ocaml4.07-ppxlib))))
(synopsis
"Base library and tools for ppx rewriters")
(description
@@ -6331,46 +6330,6 @@ OCaml AST in the OCaml syntax;
@end itemize")
(license license:expat)))
-(define-public ocaml4.07-ppxlib
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppxlib)
- (name "ocaml-ppxlib")
- (version "0.6.0")
- (home-page "https://github.com/ocaml-ppx/ppxlib")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0my9x7sxb329h0lzshppdaawiyfbaw6g5f41yiy7bhl071rnlvbv"))))
- (build-system dune-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'set-topfind
- (lambda* (#:key inputs #:allow-other-keys)
- ;; add the line #directory ".." at the top of each file
- ;; using #use "topfind";; to be able to find topfind
- (let* ((findlib-path (assoc-ref inputs "findlib"))
- (findlib-libdir
- (string-append findlib-path "/lib/ocaml/site-lib")))
- (substitute* '("test/base/test.ml"
- "test/code_path/test.ml"
- "test/deriving/test.ml"
- "test/driver/attributes/test.ml"
- "test/driver/non-compressible-suffix/test.ml"
- "test/driver/transformations/test.ml")
- (("#use \"topfind\";;" all)
- (string-append "#directory \"" findlib-libdir "\"\n"
- all))))
- #t)))))
- (properties '()))))
-
(define-public ocaml-ppx-compare
(package
(name "ocaml-ppx-compare")