aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
commit9a84da4418ac7658c5a22aee92aac63b44806145 (patch)
treef6edfab779d3be0c055fbdaf3d4f85b67913626c /gnu/packages/ntp.scm
parent2565a159fe7e62428b62801e68b943418d8d4e98 (diff)
downloadguix-9a84da4418ac7658c5a22aee92aac63b44806145.tar
guix-9a84da4418ac7658c5a22aee92aac63b44806145.tar.gz
gnu: ntp: Remove input labels.
* gnu/packages/ntp.scm (ntp)[inputs]: Remove input labels.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 43a8b6b045..f12bfd469b 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -134,14 +134,14 @@ time-stamping or reference clock, sub-microsecond accuracy is possible.")
"sntp/libevent/build-aux")))))
(native-inputs (list which pkg-config))
(inputs
- `(("openssl" ,openssl-1.1)
- ("libevent" ,libevent)
- ;; Build with POSIX capabilities support on GNU/Linux. This allows 'ntpd'
- ;; to run as non-root (when invoked with '-u'.)
- ,@(if (string-suffix? "-linux"
- (or (%current-target-system) (%current-system)))
- `(("libcap" ,libcap))
- '())))
+ (cons* openssl-1.1
+ libevent
+ ;; Build with POSIX capabilities support on GNU/Linux. This allows
+ ;; 'ntpd' to run as non-root (when invoked with '-u'.)
+ (if (string-suffix? "-linux"
+ (or (%current-target-system) (%current-system)))
+ (list libcap)
+ '())))
(arguments
`(;; Pass "--with-yielding-select=yes" so that 'configure' knows whether
;; 'select' yields when using pthreads in a cross-compilation context.