aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-08-06 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-08-06 02:00:00 +0200
commit8b40e1ea157438b8d7b614dad80be8eede05c938 (patch)
tree68ccc9ee27554ad6946fb3af0ab79b8f7e32aaa7 /gnu/packages/ntp.scm
parent1b60c48c27fdfb7461acae90a9fee4db0b63e126 (diff)
downloadguix-8b40e1ea157438b8d7b614dad80be8eede05c938.tar
guix-8b40e1ea157438b8d7b614dad80be8eede05c938.tar.gz
gnu: chrony: Use G-expressions.
* gnu/packages/ntp.scm (chrony)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm47
1 files changed, 25 insertions, 22 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 5592ed30fc..3b56580842 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -57,28 +57,31 @@
(base32 "123h2a9rpc6wbvnysvhl5pmckvynzrnqay7l00i18azrvbk0gyza"))))
(build-system gnu-build-system)
(arguments
- `(#:modules ((srfi srfi-26)
- (guix build utils)
- (guix build gnu-build-system))
- #:configure-flags
- (list "--enable-scfilter"
- "--with-sendmail=sendmail"
- "--with-user=chrony")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'stay-inside-out
- ;; Simply setting CHRONYVARDIR to something nonsensical at install
- ;; time would result in nonsense file names in man pages.
- (lambda _
- (substitute* "Makefile.in"
- (("mkdir -p \\$\\(DESTDIR\\)\\$\\(CHRONYVARDIR\\)") ":"))))
- (add-after 'install 'install-more-documentation
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/" ,name "-" ,version)))
- (for-each (cut install-file <> doc)
- (list "README" "FAQ"))
- (copy-recursively "examples" (string-append doc "/examples"))))))))
+ (list
+ #:modules
+ '((srfi srfi-26)
+ (guix build utils)
+ (guix build gnu-build-system))
+ #:configure-flags
+ #~(list "--enable-scfilter"
+ "--with-sendmail=sendmail"
+ "--with-user=chrony")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'stay-inside-out
+ ;; Simply setting CHRONYVARDIR to something nonsensical at install
+ ;; time would result in nonsense file names in man pages.
+ (lambda _
+ (substitute* "Makefile.in"
+ (("mkdir -p \\$\\(DESTDIR\\)\\$\\(CHRONYVARDIR\\)") ":"))))
+ (add-after 'install 'install-more-documentation
+ (lambda _
+ (let* ((doc (string-append #$output "/share/doc/"
+ #$name "-" #$version)))
+ (for-each (cut install-file <> doc)
+ (list "README" "FAQ"))
+ (copy-recursively "examples"
+ (string-append doc "/examples"))))))))
(native-inputs
(list pkg-config))
(inputs