aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/nss.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-16 01:12:10 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-16 01:55:34 +0100
commitceb9c6c50ed2c0d127189bb5d28832b6538aa7a2 (patch)
treecc528b9e85f93b440f3318d33e97b5a4b1a295cd /gnu/packages/nss.scm
parent18b1497673b92b6a0947839f9757a561a77d0d5f (diff)
downloadguix-ceb9c6c50ed2c0d127189bb5d28832b6538aa7a2.tar
guix-ceb9c6c50ed2c0d127189bb5d28832b6538aa7a2.tar.gz
gnu: nss-certs: Avoid top-level reference to NSS.
This is the only hammer I know for dealing with module cycles and effectively fixes, for example, ‘guix show nss’ today. It's also a very poor solution. * gnu/packages/certs.scm (nss-certs)[version, source]: Copy verbatim from the nss package rather than referring to it at the top level. Reported by several users of #guix.
Diffstat (limited to 'gnu/packages/nss.scm')
-rw-r--r--gnu/packages/nss.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index af9003e823..41b564483f 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -107,11 +107,11 @@ in the Mozilla clients.")
(base32
"0v3zds1id71j5a5si42a658fjz8nv2f6zp6w4gqrqmdr6ksz8sxv"))))))
-;;; Note: When updating, verify that the nss-certs package still builds fine
-;;; as it inherits its source from the nss package.
(define-public nss
(package
(name "nss")
+ ;; Also update and test the nss-certs package, which duplicates version and
+ ;; source to avoid a top-level variable reference & module cycle.
(version "3.71")
(source (origin
(method url-fetch)