aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/nss.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-20 21:32:14 +0100
committerMarius Bakke <marius@gnu.org>2022-11-20 21:32:54 +0100
commitbd4869c7fc35c7f1fea0405455940a5e96041374 (patch)
tree91cf0a49e6941c70670b99a033604a010ff1cc00 /gnu/packages/nss.scm
parente7b7722821ad4f16e0051abb1d92055034a8fd48 (diff)
downloadguix-bd4869c7fc35c7f1fea0405455940a5e96041374.tar
guix-bd4869c7fc35c7f1fea0405455940a5e96041374.tar.gz
gnu: NSS: Update to 3.85.
* gnu/packages/nss.scm (nss): Update to 3.85. * gnu/packages/certs.scm (nss-certs): Likewise.
Diffstat (limited to 'gnu/packages/nss.scm')
-rw-r--r--gnu/packages/nss.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 3f9d5477ec..7db9073131 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -112,7 +112,7 @@ in the Mozilla clients.")
(name "nss")
;; Also update and test the nss-certs package, which duplicates version and
;; source to avoid a top-level variable reference & module cycle.
- (version "3.81")
+ (version "3.85")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -123,7 +123,7 @@ in the Mozilla clients.")
"nss-" version ".tar.gz")))
(sha256
(base32
- "19ncvhz45dhr0nmymwkxspq9l44gaafkspxiwxbqs1hpnqxmzgx8"))
+ "15yj2gddlp68wj1k9q4q70vs6r7zx5qkbavcppmls5di212xdndg"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-3.56-pkgconfig.patch"
"nss-getcwd-nonnull.patch"
@@ -186,7 +186,7 @@ in the Mozilla clients.")
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
;; work around that, set the time to roughly the release date.
- (invoke "faketime" "2022-06-01" "./nss/tests/all.sh"))
+ (invoke "faketime" "2022-11-01" "./nss/tests/all.sh"))
(format #t "test suite not run~%"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)