aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-02-04 13:40:11 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-18 12:34:46 +0000
commitaede3fa122e38c0ab60a2ad319a4ebc62a8efd28 (patch)
tree0e8dc613fecd42e64a204bf80ca37f65f43fcb61 /gnu/packages/node-xyz.scm
parent2f1ed825afa535693f7fe32b9e3e9128cc8f99c9 (diff)
downloadguix-aede3fa122e38c0ab60a2ad319a4ebc62a8efd28.tar
guix-aede3fa122e38c0ab60a2ad319a4ebc62a8efd28.tar.gz
gnu: node-bindings: Move package in alphabetical order.
* gnu/packages/node-xyz.scm (node-bindings): Move package in alphabetical order. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index a47c525d14..bb10c885c8 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -107,6 +107,31 @@
architecture supporting plugins.")
(license license:expat)))
+(define-public node-bindings
+ (package
+ (name "node-bindings")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TooTallNate/node-bindings")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "100gp6kpjvd4j1dqnp0sbjr1hqx5mz7r61q9qy527jyhk9mj47wk"))))
+ (inputs
+ (list node-file-uri-to-path))
+ (build-system node-build-system)
+ (arguments
+ ;; there are no tests
+ `(#:tests? #f))
+ (home-page "https://github.com/TooTallNate/node-bindings")
+ (synopsis "Locate native addons")
+ (description "This package provides a helper module to locate native
+addons in a wide array of potential locations.")
+ (license license:expat)))
+
(define-public node-buffer-crc32
(package
(name "node-buffer-crc32")
@@ -1258,31 +1283,6 @@ URI to a file path. It accepts a @code{file:} URI and returns a file path
suitable for use with the @code{fs} module functions.")
(license license:expat)))
-(define-public node-bindings
- (package
- (name "node-bindings")
- (version "1.5.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/TooTallNate/node-bindings")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "100gp6kpjvd4j1dqnp0sbjr1hqx5mz7r61q9qy527jyhk9mj47wk"))))
- (inputs
- (list node-file-uri-to-path))
- (build-system node-build-system)
- (arguments
- ;; there are no tests
- `(#:tests? #f))
- (home-page "https://github.com/TooTallNate/node-bindings")
- (synopsis "Locate native addons")
- (description "This package provides a helper module to locate native
-addons in a wide array of potential locations.")
- (license license:expat)))
-
(define-public node-segfault-handler
(package
(name "node-segfault-handler")