aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-02-19 01:11:08 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-21 20:16:21 +0000
commit5b2f6a497f2adc3e0035c3e103eaeef342c3010f (patch)
treed05f8edf0f8640e80fc84bef14a2461d44d3daf7 /gnu/packages/node-xyz.scm
parentc7f76fb8372d98659584b3a1ffe46222299bd400 (diff)
downloadguix-5b2f6a497f2adc3e0035c3e103eaeef342c3010f.tar
guix-5b2f6a497f2adc3e0035c3e103eaeef342c3010f.tar.gz
gnu: node-serialport-parser-cctalk: Move in alphabetical order.
* gnu/packages/node-xyz.scm (node-serialport-parser-cctalk): Move package in alphabetical order. Change-Id: Ia849d7f2a02f2d7ba8117e031056e01239a3a5fb Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 4960d7f54c..1891caabf7 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1269,6 +1269,29 @@ Parsers are used to take raw binary data and transform them into usable
messages. This package provides @code{ByteLength}, a parser that emits data
as a buffer every time a specified number of bytes are received.")))
+(define-public node-serialport-parser-cctalk
+ (package
+ (inherit node-serialport)
+ (name "node-serialport-parser-cctalk")
+ (version "9.2.4")
+ (inputs `())
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda args
+ (chdir "packages/parser-cctalk"))))
+ #:tests? #f))
+ (synopsis "Node SerialPort parser for the ccTalk protocol")
+ (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports. The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+Parsers are used to take raw binary data and transform them into usable
+messages. This package provides @code{CCTalk}, which emits packets for the
+ccTalk protocol (an open standard for currency detectors) as they are
+received.")))
+
(define-public node-serialport-parser-delimiter
(package
(inherit node-serialport)
@@ -1381,29 +1404,6 @@ Parsers are used to take raw binary data and transform them into usable
messages. This package provides @code{InterByteTimeout}, a parser that emits
data if there is a pause between packets for the specified amount of time.")))
-(define-public node-serialport-parser-cctalk
- (package
- (inherit node-serialport)
- (name "node-serialport-parser-cctalk")
- (version "9.2.4")
- (inputs `())
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda args
- (chdir "packages/parser-cctalk"))))
- #:tests? #f))
- (synopsis "Node SerialPort parser for the ccTalk protocol")
- (description "Node SerialPort is a modular suite of Node.js packages for
-accessing serial ports. The Guix package @code{node-serialport} provides the
-recommended high-level interface.
-
-Parsers are used to take raw binary data and transform them into usable
-messages. This package provides @code{CCTalk}, which emits packets for the
-ccTalk protocol (an open standard for currency detectors) as they are
-received.")))
-
(define-public node-serialport-stream
(package
(inherit node-serialport)