aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-02-04 13:40:13 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-18 12:34:46 +0000
commit466fe22a89f642a6d2198faa5010b61f0cba8f31 (patch)
tree4c3451c848079160071a0af918c504b4e2044065 /gnu/packages/node-xyz.scm
parent51fee99e2689f201962c61a8e830c25ce6893044 (diff)
downloadguix-466fe22a89f642a6d2198faa5010b61f0cba8f31.tar
guix-466fe22a89f642a6d2198faa5010b61f0cba8f31.tar.gz
gnu: node-once: Move package in alphabetical order.
* gnu/packages/node-xyz.scm (node-once): Move package in alphabetical order. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm64
1 files changed, 32 insertions, 32 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 7fbeac5516..10e065f1da 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -401,6 +401,38 @@ Can also condense repeated slashes to a single slash and remove trailing
slashes, unless disabled.")
(license license:expat)))
+(define-public node-once
+ (package
+ (name "node-once")
+ (version "1.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/isaacs/once")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1z8dcbf28dqdcp4wb0c53wrs90a07nkrax2c9kk26dsk1dhrnxav"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'patch-dependencies 'delete-dependencies
+ (lambda args
+ (delete-dependencies '("tap")))))
+ ;; FIXME: Tests depend on node-tap
+ #:tests? #f))
+ (inputs
+ (list node-wrappy))
+ (home-page "https://github.com/isaacs/once")
+ (synopsis "Node.js module to call a function only once")
+ (description
+ "@code{once} is a Node.js module to call a function exactly one time.
+Subsequent calls will either return the cached previous value or throw an error
+if desired.")
+ (license license:isc)))
+
(define-public node-oop
;; No releases, last commit was February 2013.
(let ((commit "f9d87cda0958886955c14a0a716e57021ed295dc")
@@ -695,38 +727,6 @@ function with browser support.")
(description "@code{wrappy} is a utility for Node.js to wrap callbacks.")
(license license:isc)))
-(define-public node-once
- (package
- (name "node-once")
- (version "1.4.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/isaacs/once")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1z8dcbf28dqdcp4wb0c53wrs90a07nkrax2c9kk26dsk1dhrnxav"))))
- (build-system node-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda args
- (delete-dependencies '("tap")))))
- ;; FIXME: Tests depend on node-tap
- #:tests? #f))
- (inputs
- (list node-wrappy))
- (home-page "https://github.com/isaacs/once")
- (synopsis "Node.js module to call a function only once")
- (description
- "@code{once} is a Node.js module to call a function exactly one time.
-Subsequent calls will either return the cached previous value or throw an error
-if desired.")
- (license license:isc)))
-
(define-public node-path-key
(package
(name "node-path-key")