aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/nettle.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-05 02:09:03 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-05 02:09:03 -0400
commit683eb7c5b118440001b89944563603a39fc2ac05 (patch)
tree4cab31398debd3aa4ab60d8536b2ddb5513c92f5 /gnu/packages/nettle.scm
parent5d547f74ed50ad2065e39af5687a6ca552f53c61 (diff)
downloadguix-683eb7c5b118440001b89944563603a39fc2ac05.tar
guix-683eb7c5b118440001b89944563603a39fc2ac05.tar.gz
gnu: Remove remnants of nettle 3.5.
The source of nettle-3.5 was already using the source of nettle-3.7. * gnu/packages/nettle.scm (nettle-3.5): Rename to 'nettle'. (nettle-3.7): Remove variable. (nettle): Remove alias.
Diffstat (limited to 'gnu/packages/nettle.scm')
-rw-r--r--gnu/packages/nettle.scm16
1 files changed, 1 insertions, 15 deletions
diff --git a/gnu/packages/nettle.scm b/gnu/packages/nettle.scm
index 7088e1da4a..3fddfce692 100644
--- a/gnu/packages/nettle.scm
+++ b/gnu/packages/nettle.scm
@@ -72,7 +72,7 @@ cryptographic toolkits for object-oriented languages or in applications
themselves.")
(license gpl2+)))
-(define-public nettle-3.5
+(define-public nettle
;; This version is not API-compatible with version 2. In particular, lsh
;; cannot use it yet. So keep it separate.
(package (inherit nettle-2)
@@ -90,17 +90,3 @@ themselves.")
;; Build "fat" binaries where the right implementation is chosen
;; at run time based on CPU features (starting from 3.1.)
`(cons "--enable-fat" ,flags))))))
-
-(define-public nettle-3.7
- (package (inherit nettle-3.5)
- (version "3.7.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/nettle/nettle-"
- version ".tar.gz"))
- (sha256
- (base32
- "0qpi1qp3bcvqdsaxy2pzg530db95x8qjahkynxgwvr6dy5760ald"))))))
-
-;;; Upgrading Nettle on master would cause 10000+ packages to be rebuilt.
-(define-public nettle nettle-3.5)