aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/netpbm.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-02-12 23:21:19 -0500
committerLeo Famulari <leo@famulari.name>2019-02-12 23:23:19 -0500
commit344e0f56218f6b2680e0ab00446eed372216d420 (patch)
tree819a77b587b10179bcd74f218f6bbf7fe75782cd /gnu/packages/netpbm.scm
parentc7cf43ddec9be5389d3a2623d6414d9b55354f64 (diff)
downloadguix-344e0f56218f6b2680e0ab00446eed372216d420.tar
guix-344e0f56218f6b2680e0ab00446eed372216d420.tar.gz
gnu: netpbm: Fix a hard-coded path.
Fixes <https://bugs.gnu.org/24735>. * gnu/packages/netpbm.scm (netpbm)[arguments]: Patch a path in the 'configure' phase.
Diffstat (limited to 'gnu/packages/netpbm.scm')
-rw-r--r--gnu/packages/netpbm.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/netpbm.scm b/gnu/packages/netpbm.scm
index e5246660a2..9c0e970257 100644
--- a/gnu/packages/netpbm.scm
+++ b/gnu/packages/netpbm.scm
@@ -135,7 +135,9 @@
;; 'gsc', so look for that instead.
(substitute* "converter/other/pstopnm.c"
(("\"%s/gs\"")
- "\"%s/gsc\"")))
+ "\"%s/gsc\"")
+ (("/usr/bin/gs")
+ (string-append (assoc-ref inputs "ghostscript") "/bin/gsc"))))
#t))
(add-before 'check 'setup-check
(lambda _