aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ncurses.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-20 16:19:33 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-20 19:54:24 +0100
commit784d3b7e8e65cf9e6da6e2f3ffe3afa33f941230 (patch)
tree0aa6c81e51f32f8f245d790b89c5e89002c88ea0 /gnu/packages/ncurses.scm
parenteaa7b9664ed5ddc8c2c7372b741ea648038849c9 (diff)
downloadguix-784d3b7e8e65cf9e6da6e2f3ffe3afa33f941230.tar
guix-784d3b7e8e65cf9e6da6e2f3ffe3afa33f941230.tar.gz
gnu: ncurses: Update to 6.1.
* gnu/packages/ncurses.scm (ncurses): Update to 6.1. [arguments]: Remove APPLY-ROLLUP-PATCH-PHASE. [native-inputs]: Remove "rollup-patch" origin. Move comment.
Diffstat (limited to 'gnu/packages/ncurses.scm')
-rw-r--r--gnu/packages/ncurses.scm27
1 files changed, 7 insertions, 20 deletions
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index 4ddeef2d16..6bc98b15d8 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -40,7 +40,7 @@
(define-public ncurses
(package
(name "ncurses")
- (version "6.0-20170930")
+ (version "6.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/ncurses/ncurses-"
@@ -48,7 +48,7 @@
".tar.gz"))
(sha256
(base32
- "0q3jck7lna77z5r42f13c4xglc7azd19pxfrjrpgp2yf615w4lgm"))))
+ "05qdmbmrrn88ii9f66rkcmcyzp1kb1ymkx7g040lfkd1nkp7w1da"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1 MiB of man pages
@@ -76,6 +76,10 @@
configure-flags))
#t)))
(apply-rollup-patch-phase
+ ;; Ncurses distributes "stable" patchsets to be applied on top
+ ;; of the release tarball. These are only available as shell
+ ;; scripts(!) so we decompress and apply them in a phase.
+ ;; See <https://invisible-mirror.net/archives/ncurses/6.1/README>.
'(lambda* (#:key inputs native-inputs #:allow-other-keys)
(copy-file (assoc-ref (or native-inputs inputs) "rollup-patch")
(string-append (getcwd) "/rollup-patch.sh.bz2"))
@@ -178,8 +182,6 @@
,@(if (target-mingw?) '("--enable-term-driver") '()))))
#:tests? #f ; no "check" target
#:phases (modify-phases %standard-phases
- (add-after 'unpack 'apply-rollup-patch
- ,apply-rollup-patch-phase)
(replace 'configure ,configure-phase)
(add-after 'install 'post-install
,post-install-phase)
@@ -189,22 +191,7 @@
,remove-shebang-phase)))))
(self-native-input? #t) ; for `tic'
(native-inputs
- `(("pkg-config" ,pkg-config)
-
- ;; Ncurses distributes "stable" patchsets to be applied on top
- ;; of the release tarball. These are only available as shell
- ;; scripts(!) so we decompress and apply them in a phase.
- ;; See <https://invisible-mirror.net/archives/ncurses/6.0/README>.
- ("rollup-patch"
- ,(origin
- (method url-fetch)
- (uri (string-append
- "https://invisible-mirror.net/archives/ncurses/"
- (car (string-split version #\-))
- "/ncurses-" version "-patch.sh.bz2"))
- (sha256
- (base32
- "08a1pp8wnj1fwpa1pz3fgrmd6xwp21idniswqz8lx3w3z2nb4ydi"))))))
+ `(("pkg-config" ,pkg-config)))
(native-search-paths
(list (search-path-specification
(variable "TERMINFO_DIRS")