aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-10-19 19:29:21 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-10-24 00:33:10 +0300
commit414d6d7f3234e6230366b2f6edc32b4060f01aee (patch)
tree9c7af1ec253a65fa2bbefc52a16c1a7530af1ced /gnu/packages/music.scm
parent5f4ba1c09fa0fba1ed230b80bae9f6a4d0d2d303 (diff)
downloadguix-414d6d7f3234e6230366b2f6edc32b4060f01aee.tar
guix-414d6d7f3234e6230366b2f6edc32b4060f01aee.tar.gz
gnu: fabla: Update to 1.4.
* gnu/packages/music.scm (fabla): Update to 1.4. Reviewed-by: Ludovic Courtès <ludo@gnu.org> Change-Id: I3fbba9df343ad296a78f2e54fbe02a525a1d546f
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm46
1 files changed, 21 insertions, 25 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9c1a617ca1..548836abeb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5813,32 +5813,28 @@ mapping support, you can get looping just how you like!")
(license license:gpl3+))))
(define-public fabla
- (let ((revision "1")
- ;; The last release was in 2016. Since then a number of commits have
- ;; been added to fix build problems.
- (commit "10acf03046d980f96ed192d5acb9deb812f5c639"))
- (package
- (name "fabla")
- (version (git-version "1.3.2" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/openAVproductions/openAV-Fabla")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ybbzb86j1n5dfhzc6aa3cibkwi6q3x0c18b1w3anyibanmr1wmc"))))
- (build-system cmake-build-system)
- (arguments '(#:tests? #f)) ;there are none
- (inputs (list ntk cairomm libsndfile))
- (native-inputs (list pkg-config lv2 mesa))
- (home-page "http://openavproductions.com/fabla/")
- (synopsis "Sampler LV2 plugin")
- (description
- "Fabla is an LV2 drum sampler plugin instrument. It is ideal for loading up
+ (package
+ (name "fabla")
+ (version "1.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openAVproductions/openAV-Fabla")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13675ljfcbmxw9jdjrpn9wpvl69qxxc1hg2y9sfjkf4khajpapg9"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ;there are none
+ (inputs (list ntk cairomm libsndfile))
+ (native-inputs (list pkg-config lv2 mesa))
+ (home-page "http://openavproductions.com/fabla/")
+ (synopsis "Sampler LV2 plugin")
+ (description
+ "Fabla is an LV2 drum sampler plugin instrument. It is ideal for loading up
your favorite sampled sounds and bashing away on a MIDI controller.")
- (license license:gpl2+))))
+ (license license:gpl2+)))
(define-public sorcer
(let ((revision "1")