aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/multiprecision.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-01 15:45:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-01 15:52:37 +0300
commitcf388642ce1af18aa1711ad2e79e850bf469e520 (patch)
tree640377b52bed8d4b966dcf4516a814a4776650ad /gnu/packages/multiprecision.scm
parentb428b49d8f2953ee0c26bd7a4770a4fe27b8e306 (diff)
downloadguix-cf388642ce1af18aa1711ad2e79e850bf469e520.tar
guix-cf388642ce1af18aa1711ad2e79e850bf469e520.tar.gz
gnu: libtommath: Honor the #:tests? flag.
* gnu/packages/multiprecision.scm (libtommath)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
Diffstat (limited to 'gnu/packages/multiprecision.scm')
-rw-r--r--gnu/packages/multiprecision.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index bb68ea06bf..51ba21162c 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -470,9 +470,10 @@ number generators, public key cryptography and a plethora of other routines.")
"/lib/libtommath.a"))
#t))
(replace 'check
- (lambda* (#:key test-target make-flags #:allow-other-keys)
- (apply invoke "make" test-target make-flags)
- (invoke "sh" "test")))
+ (lambda* (#:key tests? test-target make-flags #:allow-other-keys)
+ (when tests?
+ (apply invoke "make" test-target make-flags)
+ (invoke "sh" "test"))))
(add-after 'install 'install-static-library
(lambda* (#:key outputs #:allow-other-keys)
(invoke "make" "-f" "makefile.unix" "install"