aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mtools.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2013-12-01 12:43:29 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-03 23:33:00 +0100
commitaddfc3fc0247ceb8cdec355a69958bef003136ef (patch)
treeca4d142b6c41f984327ab5dfd863e6b941b3b1e4 /gnu/packages/mtools.scm
parent889a87f08c903832e110631f59a17c11943926fe (diff)
downloadguix-addfc3fc0247ceb8cdec355a69958bef003136ef.tar
guix-addfc3fc0247ceb8cdec355a69958bef003136ef.tar.gz
gnu: Add mtools.
* gnu/packages/mtools.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mtools.scm')
-rw-r--r--gnu/packages/mtools.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/mtools.scm b/gnu/packages/mtools.scm
new file mode 100644
index 0000000000..0e418dcfb9
--- /dev/null
+++ b/gnu/packages/mtools.scm
@@ -0,0 +1,45 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 John Darrington <jmd@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages mtools)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public mtools
+ (package
+ (name "mtools")
+ (version "4.0.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/mtools/mtools-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1hxciksv7av5ilnkvwbidyxxr1gzn24lr0mz9z8drkml7780im1h"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.gnu.org/software/mtools/")
+ (synopsis "Access MS-DOS disks without mounting")
+ (description
+ "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
+or Unix system. It supports long file names and multiple disk formats. It
+also supports some FAT-specific features such as volume labels and
+FAT-specific file attributes.")
+ (license gpl3+)))