aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-05-28 23:02:27 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-31 23:26:12 +0200
commit9f7cd1fcaf99c8e8430d0b29335220701664dc54 (patch)
tree4d4c6ede54ff5128a97b6f076ad004a8fbfeab41 /gnu/packages/mpi.scm
parent57ceb64e3464c347f42bd883e394163904f928ec (diff)
downloadguix-9f7cd1fcaf99c8e8430d0b29335220701664dc54.tar
guix-9f7cd1fcaf99c8e8430d0b29335220701664dc54.tar.gz
gnu: Add updater input properties for R and Python packages.
* gnu/packages/cran.scm (r-glue, r-xfun, r-vctrs) (r-lifecycle): Turn comment about r-knitr into 'properties' field. * gnu/packages/mpi.scm (python-mpi4py)[properties]: New field.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 5c10e9b423..3786dc177c 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -422,6 +422,8 @@ only provides @code{MPI_THREAD_FUNNELED}.")))
#t)))))
(inputs
(list openmpi))
+ (properties
+ '((updater-extra-inputs . ("openmpi"))))
(home-page "https://github.com/mpi4py/mpi4py")
(synopsis "Python bindings for the Message Passing Interface standard")
(description "MPI for Python (mpi4py) provides bindings of the Message